Phpwiki blues



Has anyone successfully got phpwiki installed on DH? I’ve got the database setup and accessed, and the initial run it created all the “default” Wiki pages. Trying to click on any link, however, gives this message:

Warning: Unexpected character in input: ‘’ (ASCII=12) state=1 in /usr/local/dh/cgi-system/php.cgi on line 2578

Parse error: parse error in /usr/local/dh/cgi-system/php.cgi on line 2578

Now clearly we users can’t and don’t need to edit the binary file php.cgi, so the problem must be in how the script is talking to it - however since I did not and could not have written this script, I am at a loss for what to do.

To see the error in the wild, check here:

Any thoughts on this? getting “nice” URLs to work with an extensionless index file is far down the line now… getting urls to work at all is immediately important heh…



I’d had a wiki page up and running for about the past year. Then a few weeks ago, all my wiki pages were gone, links broke, and it stopped working. I haven’t had a chance to investigate yet, so it’s probably some config change I made. But just maybe, something changed on the server that’s not wiki friendly.


If anyone knows what happened or how to fix this I’d love to know. I installed PHPWiKi a month ago temporarily, it worked, and I’ve since deleted it.

I just tried installing it again today and now the main page will load, bot no links work. I get the same message every time:

[quote]Security Alert! The PHP CGI cannot be accessed directly.
This PHP CGI binary was compiled with force-cgi-redirect enabled. This means that a page will only be served up if the REDIRECT_STATUS CGI variable is set, e.g. via an Apache Action directive.

For more information as to why this behaviour exists, see the manual page for CGI security.

For more information about changing this behaviour or re-enabling this webserver, consult the installation file that came with this distribution, or visit the manual page.[/quote]
I also noticed that all links on the page have strange URLs:

I don’t have a directory called “cgi-system” anywhere in my home directory. The only difference I can think of between the time it worked and now is that I’m running my domain as CGI.

If anyone has any suggestions I would greatly appreciate them.


Manage your domain…

For the WEB Click on EDIT

Untick Run PHP as CGI, but be warned, I would only run the phpwiki likethis as it is insecure (Not an issue for your wiki however)…

I am running the latest build so I know it works fine…