Phpshield


#1

Hey guys… I could really use some help… I have read the dreamhost wiki’s and I am pretty much pulling my hair out nobody can help me.

Here is the error I am getting:
“extension_dir does not exist: home/itwasbo/fishpic.co/phpshield/Linux_x86-32/ixed.5.3.lin”

my php.ini contents:
enable_dl=On
extension_dir="home/itwasbo/fishpic.co/"
extension=phpshield/phpshield.5.3.lin

link to my phpinfo: http://fishpic.co/phpinfo.php
[hr]
Just wanted to update you… my error changed.

extension_dir does not exist: home/itwasbo/fishpic.co/


#2

If using the default DH setup you’ll need to load via phprc.


#3

so does this look right?

enable_dl=On
extension_dir="home/itwasbo/fishpic.co/"
extension=home/itwasbo/fishpic.co/phpshield/ixed.5.3.lin


#4

Yes, but you don’t need to set an ext directory when setting the full path to an extension :wink:


#5

No. Don’t change extension_dir — changing it from the default value may cause PHP core extensions (including important ones, like mysql.so!) to fail to load correctly.

Specify the full path to your extension instead. This should be all you need:


#6

so just:
enable_dl=On
extension=home/itwasbo/fishpic.co/phpshield/ixed.5.3.lin

or should I get rid of the enable_dl?


#7

First of all: You’re still missing the first slash before “home”.

As far as enable_dl goes, I’m not sure. If the documentation for phpShield says to turn it on, I guess you should, but I’m not sure why it would be necessary if you’re already loading the extension in your phprc.


#8

Thanks Andrew F. It seems to take a while for the php.ini changes to take effect? Is there something I can do to make it recognize them quicker?


#9

enable_dl is on by default. Creating a setting will only lead to confusion.

^ Just do that (as advised). Changes will be reflected after the currently running process dies.


#10

http://fishpic.co/info.php

I just got rid of the error from phpshield… I thought i got it installed right?? Can you tell from the phpinfo() link?? I am getting this error and the script help site told me that I have phpshield installed wrong? I am so confused. The error is: Fatal error: Call to undefined function session_start() in /home/itwasbo/fishpic.co/classes/config.php on line 11


#11

Sounds like you’ve set up a full custom php.ini, not a phprc. This makes your PHP installation end up missing important default settings, like directives to load the session extension.

Rename “php.ini” to “phprc”.


#12

/home/itwasbo/.php/5.3/php.ini phprc

Remove everything except the extension= line that loads the module.

phpShield is loading - so you’re almost there :wink: