Phpsessid

software development

#1

How do I stop PHPSESSID from being appended to URLs? Anyone have any tips?


#2

You’re going to have to give us some more information. Where are you seeing this phpsessid? Are you using a 3rd party app like Mambo or Drupal, or…? Give us some more information and maybe a link as well.

–Matttail
art.googlies.net - personal website


#3

That’s not a function of PHP. It’s the script you’re using that’s doing this. Authors do this to get around the possibility users might not have cookies enabled.


yerba# rm -rf /etc
yerba#


#4

I thought I read in one of the php books, that the session is stored in the url if the user has cookies disabled.
Silk


#5

I normally throw up a htacess file with the following:

php_flag session.use_trans_sid off

That usually gets rid of it. But that method isn’t working on Dreamhost servers.


#6

That is because that method only works on mod_php installs. DH is using PHP CGI.

really? interesting. You could be right. But I do know there’s apps that puts it up there regardless (phpBB)


yerba# rm -rf /etc
yerba#


#7

Well… anyone know of a way to get rid of it when PHP runs as CGI?


#8

Just a guess, but wouldn’t mod rewrite take care of it. There are some tutorials somewheres about beautifying urls.
Silk