Phprc suddenly stopped working to load zend_extension IONCUBE - [SOLVED]


#1

Hi,

I’ve been using a custom phprc file since at least half year without any incident. Suddenly yesterday my site stopped working because I use IONCUBE extension (that I load in the phprc file) was missing in the php.ini

phpinfo() shows that is completely ignoring my phprc. I tried to downgrade to php 5.3 (CGI and FastCGI) without success. I tried configuring the entire php.ini in the ~/.php/5.4 directory but unfortunately didn’t work either.

I believe something could be wrong with george-taylor instance.

My site is offline since this issue.

Any help would be much appreciated !

Regards,
Federico.


#2

Solved this issue by upgrading PHP from 5.4 to 5.5.

Now I can see:
Additional .ini files parsed /etc/php55/conf.d/imagick.ini, /home/myusername/.php/5.5/phprc

But for being honest, I am quite concerned…

Eventhough this is the firs time I have an outage in Dreamhost (almost a year running in here) it’s been almost 9 hours since I’ve created a ticket to Dreamhost Support without any response…


#3

Same problem (with intl extension), same solution. But then I realized that someone changed phprc file (for 5.4) permissions and that caused the issue in the first place; giving it a 0775 solved in 5.4 too.