Phprc suddenly stopped working, Dreamhost support doesn't reply!


#1

Hi,
I’ve been used a custom phprc file, containing just two lines:
zend_extension = /home/myusername/ioncube/ioncube_loader_lin_5.3.so
max_execution_time = 600
since long time ago.

It always worked, I need to encrypt some files with ioncube and it worked without problems. Yesterday it suddenly stopped working, if I try to execute encrypted files, I get:

“Site error: the file /home/…/test.php requires the ionCube PHP Loader ioncube_loader_lin_5.3.so to be installed by the website operator. If you are the website operator please use the ionCube Loader Wizard to assist with installation.”

The reason why it doesn’t work is that the file phprc is not taken into consideration anymore, even if I try to set other php.ini parameters and then check a phpinfo() file, I can see they are ignored (yes, I klled the php process before checking). I haven’t touched anything yesterday that could have affected the phprc reading.

Can this issue be related to a new version of PHP installed by Dreamhost? I can see it is 5.3.27, build date sept 12 so I guess it could have been installed in the last days…

I tried several time to open a ticket but Dreamhost doesn’t reply, even the automatic message (“we have received your support request”) which, as far as I remember, is always sent, hasn’t arrived in my mailbox.

Any clue? I don’t really know what to do and my site is offline since yesterday…

Thanks a lot.


#2

We did recently deploy a new version of PHP — it’s possible that the “phprc” functionality was inadvertently left out of the build. I’ve let the people involved know, and we’ll get back to you as soon as we figure out what’s happened.


#3

now, in order to get the phprc functionality back, they moved my domain to php 5.4 without saying anything before…and that totally broke my script execution!!! I’m still debugging trying to understand why I get an internal server error now (with 5.4), without getting any help from the support!


#4

It’s just crazy that I’m spending so much time in debugging something you broke by mistake and NOBODY IS TRYING TO HELP ME…I’ve never heard about moving a site in production from php 5.3 to php 5.4 without saying anything before to the customers! PLEASE TELL ME IF AND WHEN YOU WILL BE ABLE TO FIX the issue with php 5.3…why this is not on http://www.dreamhoststatus.com/ ?


#5

Sorry for the issues you experienced with the php upgrade. The php package on your server has been reverted to the previous version, while investigation and correcting of the upgraded package is done. Please give the php 5.3 version another try and it should have the same functionality as previously.