PHPNuke not compatible with php4

apps

#1

Some of my scripts are specifically required to have PHP4, but running in PHP4, PHPNuke spits out:

Access Denied

On the admin page. Anyone know of a workaround for this?


#2

Can you clarify?

Do you mean your files use the .php4 extension?


#3

PHP version 4.

A default installation of PHPNuke throws out that error in the admin file if I switch to PHP version 4, opposed to 5.

Unfortunately the scripts I want to run require v4, and oddly enough PHPnuke is said to have poor v5 support, but I didn’t see a problem. Just need to figure out how to get rid of the error.


#4

Can you say what the script is doing that might be causing the problems? Also check the file permissions. Another thing would be to check if you are using full url’s for includes and the like (http://…) as that is disabled by default on DH shared servers.

Check out Gordaen’s Knowledge, the blog, and the MR2 page.