PHPnuke at Dreamhost

apps

#1

I am getting ready to install PHPnuke at Dreamhost and am wondering if I need to run it as php-cgi? I would be embedding Gallery within it (it should run as a module) so I guess that would run as php-cgi. I’ve read some threads about installing it over in the programming forum, but is there anything I should look out for that might trip things up? I’ve got a mySQL database all ready to go. Are there people using it here? Any caveats?

Thanks in advance.


#2

Nuke doesn’t require this, IIRC, but Gallery does.


#3

Well, a month later, I’m finally getting around actually installing PHPNuke. Is anyone successfully running 6.8 at Dreamhost yet? I’ve seemed to install the scripts fine and populated the mySQL database, but when i go to run admin.php, I get these errors;

Warning: Failed opening ‘language/lang-.php’ for inclusion (include_path=’.:/usr/local/lib/php’) in /home/.jackdandy/arted/aecontent.net/members/html/mainfile.php on line 166

Warning: Failed opening ‘admin/language/lang-.php’ for inclusion (include_path=’.:/usr/local/lib/php’) in /home/.jackdandy/arted/aecontent.net/members/html/mainfile.php on line 181

Warning: Failed opening ‘themes//theme.php’ for inclusion (include_path=’.:/usr/local/lib/php’) in /home/.jackdandy/arted/aecontent.net/members/html/header.php on line 31

Fatal error: Call to undefined function: themeheader() in /home/.jackdandy/arted/aecontent.net/members/html/header.php on line 47

I haven’t touched mainfile.php, but it seems that the hardcoded paths must be breaking.

When I run analyze.php I get lots of warnings about PHP security issues but also get an (obviously) erronous message that my PHPNuke is an old version (it’s the latest one).

I’m thinking of trying to install 6.5 instead. Maybe 6.8 is looking for a more recent version of mySQL or PHP(monkey, php 4.3.2 mySQL 3.23.5)?

thanks for any help!


#4

I think my problem is in my config.php file. It’s finding the database but I don’t think I have all the system varibles set up right

unclear about the correct path for:

$prefix = “this_one”;
$user_prefix = “or_this_one”;

working on it now.

I see there’s also a 7.x beta, won’t go there just yet!


#5

found my answer,
$prefix and $user_prefix is “nuke”, not name of database even if different from nuke. doink!

$prefix = “nuke”;
$user_prefix = “nuke”;

site up and running, now to do something with it!


#6

I am having the same problem, was sent here by tech support to see if I could find somone to install it for me… If have solved this problem or anyone else knows what the problem is, please let me know.

Thanks
TB@EvilSolutions.com


#7

Yes, I have read the thread, although, when it comes to scripts, PHP, and installation ect… I am Lost to what they are talking about. There was a message with the same error I am getting, although, I am not sure of the correction? Only correction I understand is the one where the Database tags thingies are changed, and mine are already NUKE… So, I am back to the beginning.


#8

ardco writes

[quote]Nothing against nukes, but you might also take a look at phpWebsite, if you haven’t already.

[quote]$prefix and $user_prefix is “nuke”
[/quote]

Just don’t know why that wasn’t immediately obvious from those error messages. :>

[/quote]

'cause I’m no expert! but, after looking at the database tables it was obvious.

I’m looking at phpWebsite again, thanks for the recommendation. It seems like it might be a better choice for my needs. The Nukes are cool but there seems to be a fair amount of security issues with using them and I’m not sure if they’re really the right choice for what I need. I’m trying to find open source tools to create a community site for art teachers, where they can share ideas, lessons, post galleries of their art or their students art, have a BB, personal pages, Single sign-in… AND… the interface has to be really intuitive because I’m dealing with a (mostly) techno-phobic community.

Nuke’s module system seems to answer a lot of that. But, I’m checking out PHPwebsite now. Do you have it loaded at Dreamhost?


#9

–sorry, the above post was mine. Didn’t realize I wasn’t logged in.

the artgeek.


#10

Well, as I slowly work on this, I’ve got a new problem…

I’ve got PHPnuke working fine, but have run into troubles trying to get Gallery to function as a module. Actually I think it’s directly tied into the safe mode (php-cgi) that we need to run Gallery in at Dreamhost.

This is what happens.

I can configure, run and post images into Gallery from outside PHPnuke, (in safemode, php-cgi) so the install seems to be fine.

From within PHPnuke I can administer Gallery, it looks like it’s working, but if I try to add any pictures I get a slew of open_basedir warnings and it fails.

like this:

  • Adding Z2.craters.jpg
    Warning: open_basedir restriction in effect. File is in wrong directory in /home/.jackdandy/arted/aecontent.net/members/modules/gallery/classes/Album.php on line 625

Warning: open_basedir restriction in effect. File is in wrong directory in /home/.jackdandy/arted/aecontent.net/members/modules/gallery/platform/fs_unix.php on line 26

Warning: open_basedir restriction in effect. File is in wrong directory in /home/.jackdandy/arted/aecontent.net/members/modules/gallery/util.php on line 596

Warning: getimagesize: Unable to open ‘/home/arted/aecontent.net/members/albums/album01/Z2_craters.jpg’ for reading. in /home/.jackdandy/arted/aecontent.net/members/modules/gallery/util.php on line 596

Error: Invalid image: Z2_craters.jpg!
Need help? Look in the Gallery FAQ
Warning: open_basedir restriction in effect. File is in wrong directory in /home/.jackdandy/arted/aecontent.net/members/modules/gallery/platform/fs_unix.php on line 55

Warning: fopen("/home/arted/aecontent.net/members/albums/album01/photos.dat.0", “wb”) - Operation not permitted in /home/.jackdandy/arted/aecontent.net/members/modules/gallery/platform/fs_unix.php on line 55

I seem to be in a catch22. I searched the Gallery and Nukedgallery forums for advice and came up empty. Has anyone successfully implemented this at Dreamhost (Gallery as a module of PHPnuke?). I know that Gallery can’t really support safemode because of all the varibles.


#11

Also, this might be of interest to folks trying out CMS’s. This site has installed a lot of scripts and will let you log in as the administrator and play around with them so you have a better idea of which one you want to use.

check it out:


#12

seek and ye shall find…

I started thinking that, to solve my problem I’d have to run Nuke as php-cgi, but wasn’t sure if it would work. This post, from the K-base seemed to confirm that it would. I followed this exactly and it solved the problem.

User Post (2003-01-26 21:10:40 by gsteinmon )
I had a little trouble running Gallery both on it’s own and with postnuke. Here is what worked for me: After finishing the Gallery setup script and saving my settings, I ran secure.sh. I then added “AddType php-cgi .php” line to the .htaccess file within the main directory. Then I created an .htaccess file in the “platform” sub-directory with the only line of text being “AddType php-cgi .php”. I also needed to add an .htaccess file into the main postnuke directory with the "AddType php-cgi .php " line. That seemed to work for me.

thank you gsteinmon!!