phpMyAdmin warning of MySQL version issues

software development

#1

For last X weeks, whenevr I access my databases using phpMyAdmin (indispensable), I get warning that “Your PHP MySQL library version 5.0.16 differs from your MySQL server version 5.0.24a. This may cause unpredictable behavior.” at bottom of initial page.

I think I first saw this about same time that phpMyAdmin was updated at DH to 2.11.0

Warnings like this make me nervous. I have not YET (knock wood) be aware of any “unpredictable” behavior. Wait: I take that back: sometimes phpMyAdmin seems to want to INSERT new record when I have asked it to EDIT a record.

Anyone else noticed this? I appreciated DH keeping software updated, but does this need attention? Should I be contacting support.

Thanks in advance for sharing any insights.


#2

Support has been made aware of it, and I have been told that it will require a DH admin to correct the warning.

That said, it can’t hurt to put in another support request regarding the issue (maybe if enough users keep reporting it, it will rise in the queue? :wink: )

FWIW, in spite of the warning, I have not experience any strange or anomalous behavior with phpMyAdmin with my databases so far.

–rlparker