phpMyAdmin Trouble - can't do anything!


#1

I’ve been having weird troubles with phpMyAdmin the past two days. I had been browsing a table for a while, deleting a few rows, when it stopped responding. I could browse all the other tables in the database, but not the one I had been using. I waited a few hours, then contacted support because it still didn’t work.

Now I can’t browse or use any table in any of my databases! I can log into phpMyAdmin and view the list of tables, but if I click them nothing happens (in Firebird). In IE, I get an error message ([code=SERVER_RESPONSE_CLOSE] The server closed the connection while reading the response. Contact your system administrator.)

It’s been over a day and I still haven’t heard back from support, and I’m still 164 in queue. I really want to get into phpMyAdmin and I can’t. I’m not familiar with other methods of editing mySQL data, so I have no other option right now.

Also, from what I can tell, I can’t create and add rows to the database using a PHP script, but I can update existing rows. All info is still in my tables, though. I’ve got fairly recent backups, so I’m OK there, but I don’t want to lose and re-add my data, that would really be annoying.

Anybody else having this trouble? Or have any ideas?


#2

I had trouble with my blogging program communicating to the mySQL database over the weekend as well. It just started working again yesterday (12/2/03) for some reason. I have no idea what happened (I didn’t make any changes) and neither did the DreamHost folks. But, they did respond to my queries


#3

And now it’s back down again. What is happening??? This is only happening for my subdomain.

bay.takoyaki.org


#4

The web service for bay.takoyaki.org must be improperly configured, as I only get EOF when trying to submit an HTTP request using telnet or libwww-perl. DNS resolves to the same address as takoyaki.org but it appears something on that machine does not like Host: bay.takoyaki.org at all, as not specifying that header returns a normal response with the “service is unavailable” message.

Hmm…you didn’t happen to try using the same subdomain for both a web site and the mysql database did you? Just curious…
:cool: Perl / MySQL / HTML CSS


#5

Hmmm. no, I have a different name for the mySQL database. The strange thing is, the site has been working fine since maybe May or June. Only since last weekend have I had trouble.

I can access other files at the subdomain (like hitting my css file directly, or http://bay.takoyaki.org/test.html), but any .php file that talks to the mysql database has problems.

any other ideas?


#6

Well, now it is saying that that domain is being parked with DreamHost.

:cool: Perl / MySQL / HTML+CSS


#7

Yeah, that was me. I decided to park it, then switch it back to fully host to see if that would have any effect. But it is the same. :frowning:

I think the next thing I am going to try is to do a fresh install of my blogging program on another subdomain, then see if that one can communicate with the mySQL database. Maybe that is where the problem lies.