phpMyAdmin hostname


from the control panel’s goodies -> mysql area there was a link for phpMyAdmin & it didn’t work. I found out that it hyper-linked to where it is one of my domains fully hosted by Dream Host. I did some checks and I found out that & the 2 other DNS servers did not answer to DNS lookup for, thus from outside of Dream Host it does not get our browsers to the server where we can get phpMyAdmin.

However, I think from within Dream Host’s data center, there are several internal DNS cache servers that happens to resolve corrected. I found out this when I couldn’t not get browser to phpMyAdmin, so I did SSH into Dream Host and used shell command to get mysql job done.

I realized that specifying localhost from ssh won’t work because the mysql server is not the same as the one I SSH into. I tried instead of localhost in a command line similar to the one below, and it worked:

[quote]mysql -uUserName -p -h mySQLdb


Actually not the above command rather I was doing a mysqldump instead but using instead of localhost.

My feedback to Dream Host is some of the automatically generated hostnames didn’t quite work ideally in the DNS side. Custom MX is also a bit buggy because it did let us specify the usual priority scale e.g. 0,10,20,30 for each MX. I tried to edit it a bit and one of my domain got down with email because dig can not get any MX answers from even any more. Hope it is temporary.

I hope some engineer of Dream Host fix the hostname or link for us to get to phpMyAdmin. :slight_smile:

Thanks & regards


phpMyAdmin works fine for my domains.

Please check the following:

  1. Check that your domain’s nameservers are set to,, and If you’ve registered the domain at dreamhost itself the control panel will give you the info, if not, you’ll have to go back to your registrar’s control panel.
  2. Check that there is an A record for mysql as a DNS entry for the nameserver for your domain.

I could be the case that,, and are not the nameservers for your domain. At any rate, the behavior you are experiencing isn’t typical for the “standard” setup so we just have to figure out what your setup is.

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options


Hi my NS are all correctly set automatically by Dream Host when I setup as Fully Hosted.

Since there had been scripts to setup this, I belive these standard dreamhost defaults such as SQL host and MX etc should be set by scripts instead of user.

I don’t have any sure idea where to point these address to other then localhost as a new Dream Host user. :frowning:

If I did I would had it setup manually already. My suggestion is scripts should cover this.

Seemingly the Apache & SQL are on different machines / different IPs.

Thanks for the respond :slight_smile: