phpMyAdmin Browse Button


#1

I’ve noticed recently that phpMyAdmin was updated. There’s just one thing that bugs me about the update and I was wondering if there is a setting to allow it to do what I want.

The little browse icon (beside the name of the table) on the table listing no longer brings you to the browse tab for that table but to the structure tab. Is there a way to set this back to the way it was before and bring me to the browse tab?

Thanks,

Gathilas


#2

I’m not 100% sure on this as I don’t have a DH account yet so cannot check to confirm but I do know that between two different versions of phpmyadmin they had swapped the browse icon and the link to the tables around - if you click on the table name itself this should bring up the browse whereas before that would bring up the structure. I don’t know why phpmyadmin did this though :s


#3

The name itself seems to also bring me to the structure tab. The icon itself is called “b_sbrowse.png” so I would think it would take should take you to the browse tab.


#4

Which version of phpMyAdmin is it? On mine, it says it’s 3.3.7 and the clicking the browse icon takes me to the usual Browse tab with the data for that table.


#5

I’m on 3.3.7 as well. We could be running on different servers/installs though. I actually have databases on a couple of dreamhost’s mysql servers and both are taking me to the structure tab.


#6

I am having the same issue, also using v3.3.7 on the gordo:pocasangre server. Brief search of SourceForge bug list did not find anything. Help! Very annoying.


#7

yeah, it’s still doing this. It’s a setting in the config file which unfortunately we have no control over. I was thinking of sending a ticket in but for something so small I’m not sure.

Here are some links on how to fix it:


http://www.lighty2go.com/forum/showthread.php?tid=52


#8

What setting? It’s not tough for us (at DreamHost) to change it, we just need to know what to change. :slight_smile:


#9

From what I can tell it’s in the config.inc.php file and this variable has to be changed

$cfg[‘LeftDefaultTabTable’]

to

$cfg[‘LeftDefaultTabTable’] = ‘sql.php’;

It would be awesome if you could change it. Do you need to know the servers which my databases are on?

Thanks,

Gathilas


#10

I just submitted a “suggestion” to make an official request for this change/fix. You are correct, a minor change in the config.inc.php file line to $cfg[‘LeftDefaultTabTable’] = ‘sql.php’;