Phpfox help. FFMpeg and FFMpeg-php

software development

#1

i have phpfox installed on my site, however i get the folllowing error:
Missing class “ffmpeg_movie”. Please make sure FFMpeg and FFMpeg-php is properly installed
i tried installing from this article at
http://wiki.dreamhost.com/Php-ffmpeg

but i get the following error and cannot install this: Please help…
The error is as follows:

[electra]$ cd ~/ffmpeg/ffmpeg-php-0.5.0
-bash: cd: /home/eao/ffmpeg/ffmpeg-php-0.5.0: No such file or directory
[electra]$ phpize
Cannot find config.m4.
Make sure that you run ‘/usr/local/bin/phpize’ in the top level source directory of the module

[electra]$ ./configure
-bash: ./configure: No such file or directory
[electra]$ make
make: *** No targets specified and no makefile found. Stop.
[electra]$ make install
make: *** No rule to make target `install’. Stop.


#2

An ffmpeg directory probably doesn’t exist unless you manually set it up. The instructions in the Wiki don’t mention creating an ffmpeg directory in $HOME, but then say to cd into it. Maybe that’s where your problems begin.

Try just cd ~/ffmpeg-php-0.5.0 and then ls to see if config.m4 is there.

Maximum Cash Discount on any plan with MAXCASH


#3

i get to phpize but his is what i get:

[electra]$ phpize
Configuring for:
PHP Api Version: 20020918
Zend Module Api No: 20020429
Zend Extension Api No: 20050606
Cannot find autoconf. Please check your autoconf installation and the $PHP_AUTOCONF
environment variable is set correctly and then rerun this script.
…how do i go about installing autoconf…


#4

I’m having the same problem today with the “Cannot find autoconf”. Were you able to resolve this yet?

Dave


#5

#!/bin/bash
curl -O http://[source]/autoconf-2.61.tar.gz
tar -xzf autoconf-2.61.tar.gz
cd autoconf-2.61/
./configure --prefix=[location of installation] # ($HOME, $DOMAIN, etc) #
make
make install

Maximum Cash Discount on any plan with MAXCASH


#6

still cant get it working

[electra]$ make install
Making install in bin
make[1]: Entering directory /home/.whim/eao/autoconf-2.61/bin' make[2]: Entering directory/home/.whim/eao/autoconf-2.61’
make[2]: Leaving directory /home/.whim/eao/autoconf-2.61' make[2]: Entering directory/home/.whim/eao/autoconf-2.61/bin’
make[3]: Entering directory /home/.whim/eao/autoconf-2.61' make[3]: Leaving directory/home/.whim/eao/autoconf-2.61’
test -z “//bin” || /bin/mkdir -p “//bin”
/usr/bin/install -c ‘autom4te’ ‘//bin/autom4te’
/usr/bin/install: cannot create regular file //bin/autom4te': Permission denied /usr/bin/install -c 'autoconf' '//bin/autoconf' /usr/bin/install: cannot create regular file//bin/autoconf’: Permission denied
/usr/bin/install -c ‘autoheader’ ‘//bin/autoheader’
/usr/bin/install: cannot create regular file //bin/autoheader': Permission deni ed /usr/bin/install -c 'autoreconf' '//bin/autoreconf' /usr/bin/install: cannot create regular file//bin/autoreconf’: Permission deni ed
/usr/bin/install -c ‘ifnames’ ‘//bin/ifnames’
/usr/bin/install: cannot create regular file //bin/ifnames': Permission denied /usr/bin/install -c 'autoscan' '//bin/autoscan' /usr/bin/install: cannot create regular file//bin/autoscan’: Permission denied
/usr/bin/install -c ‘autoupdate’ ‘//bin/autoupdate’
/usr/bin/install: cannot create regular file //bin/autoupdate': Permission deni ed make[2]: *** [install-binSCRIPTS] Error 1 make[2]: Leaving directory/home/.whim/eao/autoconf-2.61/bin’
make[1]: *** [install-am] Error 2
make[1]: Leaving directory `/home/.whim/eao/autoconf-2.61/bin’
make: *** [install-recursive] Error 1

why does it say permission denied…


#7

It’s either trying to alter files outside your environment or the double slash is upsetting it.

Are you using ./configure --prefix=$HOME ?

Maximum Cash Discount on any plan with MAXCASH


#8

just cant get this working no matter what i do. can anybody do this for me and i will pay him/hher