phpBB3 and Jabber

apps

#1

Hi!

I just signed up for a Dreamhost account and was looking forward to finally use Jabber for my web applications. First of all, I tried using it with phpBB3.

Well, it didn’t work - as most people here seem to know. Have anyone here at all managed to integrate the Jabber server with phpBB3? I found several threads where people had the same problems as me, but no one posted any solutions…

Well, here’s the situation:
When trying to configure the connection, I enter the following:

Server: mydomain.com
Port: 5222 (standard)
SSL/TSL? No (I have no SSL certs)
User: forumbot (no @mydomain.com part - as it should be in this context)
Password: thecorrectpassword

When I then try the connection, it fails with the following error:

[quote][code]Information

Could not authenticate.

SEND: <?xml version='1.0' encoding='UTF-8' ?>

SEND: <stream:stream to=‘mydomain.com’ xmlns='jabber:client’
xmlns:stream=‘http://etherx.jabber.org/streams’ version=‘1.0’>

RECV: <?xml version='1.0'?><stream:stream xmlns:stream='http://etherx.jabber.org/streams
id=‘47AA1FDB’ xmlns=‘jabber:client’ from=‘mydomain.com’>

Timeout, no response from server.

[/code][/quote]
(Please note: I used a localized version of phpBB so the first error message may therefore not be the exact same being used on phpBB3’s default language. The rest of the body is exactly like it was presented to me, except my domain have been switched to mydomain.com and I added some line breaks to increase readability.)

I have searched many places for answers. People on Dreamhost seem to have the same problems as I do, but there are more people having it, too.

It seems like these issues could come from firewall rules not allowing traffic on port 5222, but when I try to telnet into the server on this port, no problem seem to occur. A traceroute indicate that the packets only does a direct jump from my shell to the server, and this should also apply for the PHP scripts, too, right?

I have two other ideas, though…

Idea #1: Dreamhost have an old Jabber server.
I’ve seen some people post that the Jabber server here is outdated. I don’t know if this has changed since those posts or anything, but this could be something. phpBB3’s jabber code - being part of a forum - might be missing fault tolerant code / legacy server compability / expect some certain output from a “modern” jabber server and not understand the output being received. “RECV” in the error seems to indicate that the server actually responds, and the same XML come up when I telnet’ed.
XMPP works by handshake, login, querying, etc. by my understanding, and it seems like a handshake is taking place, but phpBB3 quits sending more data after the server responded and the connection then times out.

Idea #2: Apache proccess have different rights than my shell user.
Yes, this might seem strange, but I’m just proposing stuff here. A difference between my user and Apache’s user is rights. What if Apache have reduced rights when communicating on the network? Could I be on to something? Perhaps some weird option in xinetd I know nothing about… Perhaps mod_security? I don’t know…

Well, I’m out of ideas by now. Anyone else want a take on this? I’d appreciate a semi-quick answer as the forum in question are to be unveiled in a few days, and the users from my last web host are waiting for it – no reason for you to help me, but a reason for me to worry. :wink:

Well, thanks in advance!
Sincerely,
Magnus Bergmark


#2

I get the same error… with my install of phpBB v3. If anyone figures this out, let me know