PHPBB2 Installation troubles

software development

#1

Hey folks, I’m trying to install a PHPBB2 forum for a friend of mine over at phoenixstar.nu and we’re having problems. I’ve set up the database, assigned a user, but when I go to enter the information and such, it comes up with the error “Could not connect to server”. Has anyone run into this wall before, and if so, could you tell me a way around it? Is there something I’ve done wrong? o.O Any help’ll be much appreciated. Thanks.


#2

I haven’t used this software, but my bet is that you’ll get more useful help if you include relevant config file snippets (with as little changed as possible - ie probably only the passwords).


#3

I’ve installed PHPBB2 three times recently with no problems - can you post more details about what you’ve done? Might just be an environment variable.


#4

Well let’s see… I’ve built the database using the online web thingy provided by Dreamhost, assigned a user, etc. I put all the information necessary in and zip, zilch, nada. Nothing. Any chance you could help walk me through the process? Maybe just make a step-by-step list? I’m at wit’s end.


#5

When I install it, I just follow their installation instructions (found in install.html). Boiled down, that is:

  1. Make the database and user (about 12 hours in advance).
  2. Upload everything to the server.
  3. Go to the installation page and enter all the data. (don’t put http:// in front of your domain/server name!)
  4. Click Submit, wait for table creation to finish (I sometimes check the db at this point to make sure that it’s done).
  5. Remove the leftover files (see Important Security blah blah section for details).
  6. Open the forum!

I haven’t had any problems, but I also go through the mySQL user and db creation process about 12 hours before I’ll be installing phpBB, just in case.

You haven’t really given me details on exactly when this error is occuring - when you click Submit to set up the tables? when you enter phpBB for the first time? so this is the best I can do right now.

If you can give me more details, I can try to help you out more.


#6

Actually I worked it out. I dunno, it was an odd error. I just tried the install and it’s fine. Might have been a connection issue. Thanks for the help though!