PHPBB Patch installation

apps

#1

Got the bulletin from Dreamhost last night (thanks guys - you totally rock) about needing to upgrade because of security issues and what not. I decided instead of doing a clean in stall or using the changed-files option, I was going to use the Patchfiles install instead.

And then hilarity/frustration ensued.

Reading their install procedures was like stereo instructions…

[quote]
A number of patch files are provided to allow you to upgrade from previous stable releases. Select the correct patch, e.g. if your current version is 2.0.10 you need the phpBB-2.0.10_to_2.0.11.patch. Place the correct patch in the parent directory containing the phpBB 2 core files (i.e. index.php, viewforum.php, etc.). With this done you should run the following command: patch -cl -d [PHPBB DIRECTORY] -p1 < [PATCH NAME] (where PHPBB DIRECTORY is the directory name your phpBB Installation resides in, for example phpBB2, and where PATCH NAME is the relevant filename of the selected patch file). This should complete quickly, hopefully without any HUNK FAILED comments.[/quote]

So I did some guessing at how to install the page. (patch -cl -d baseballboards.net (the directory I am using) -p1 < phpbb-2.0.11.patch ) and the reply I get is simply a blank line on hyperterminal.

can someoen help me out here? PHPBB support hasn’t said jack to me or someone else who is having the same type of problems on his hosting company.

Thanks


#2

Hi Stonegauge,
After several tries, I finally upgraded with the patch last night. From the root directory of my forum (i.e.; domain.com) I ran this command:
patch -cl -d phpbb -p1 < phpBB-2.0.10_to_2.0.11.patch

I was at version 2.0.10. If you are at a different version, you need to type that instead.

HTH!

On a side note -
If you do have a successful install but users have trouble logging in - from the administration panel check the configuration screen and make sure the SSL is set to disabled for secure ssl (unless you use ssl). Otherwise, I didn’t have any problems. I also had a browser window open to the administration panel prior to the upgrade - which helped because I wouldn’t have been able to log in. But that may not happen in your case.

Hope


#3

I’m doing something wrong here because I’m getting the same outcome while on Telnet.

I’m patching up from 2.0.8… Should I have everything from the patch file installed into a directory with the same name as the patch? Or should I just take the ZIP contents of the patch and place them in my directory and then run the patch?


#4

Let me take a look at my history and see. I’ll see what I can find. But for starters - I used the tar file not the zip and opened that via telnet from the command line.

Hope


#5

I’m sorry if this sounds a little confusing - but I too was confused by the instructions. It looks like I first untarred the file into my root directory. Seeing that it didn’t look right (because it was creating files in the root directory that were in the actual phpbb directory already) I then I untarred it into the phpbb directory and then from the root directory I ran the patch command.

I think if you have a zip file, you have to open it first and then upload it to the server but I’m not sure about that. That’s why I use the tar file - it’s more automatic. The file I downloaded from the PhpBB site is phpBB-2.0.11-patch.tar.bz2. I then uploaded it to the server and opened it from the command line. If you want to try that and need help untarring (I think that’s what it’s called), let me know.

Hope


#6

I usually use the Zip files so that is the difference betweent he two of us I guess.

How do you “untar” (I realize it the tar.gz compression you are talkign about ) from telnet?


#7

Hi Stonegauge,
I untar using this command:
tar -jxvf phpBB-2.0.11-patch.tar.bz2

Hope


#8

And you place the file in the directory phpbb is in or the root of your web sites entirely (meaning where mail is along with other domains and such?)


#9

I think what finally worked was putting it into the phpbb directory and opening it from there. Then I ran the patch command from the root directory and that seemed to work. Frankly, I tried several things but I believe the above brought about the desired result.

When you say root directory with other domains - that’s not the directory I was referring to. When I refer to root directory - that means, www.domain.com/ When I refer to the phpbb directory - that means www.domain.com/phpbb/. My forum is placed inside the www.domain.com/phpbb directory.

If you’re not sure what you should do, consider posting on the phpbb boards - they’re very good about answering.

Hope


#10

I went to my board directory where i have the file (cd baseballboards.net ) and then ran the command. This is what came back.

[harpo]$ tar -jxvf phpbb-2.0.11.patch.tar.bz2
tar (child): phpbb-2.0.11.patch.tar.bz2: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors

grrrrrrr


#11

If the tar file is in the directory baseballboards.net then it should have opened. From the command line (via telnet) cd to baseballboards.net and type dir and see if phpbb-2.0.11.patch.tar.bz2 is listed. If not, then you need to upload it to that directory.


#12

[harpo]$ cd baseballboards.net
[harpo]$ dir
admin form.html memberlist.php robots.txt
cache groupcp.php modcp.php search.php
common.php home.html phpBB-2.0.11-patch foo
config.php images phpBB-2.0.11-patch.tar.bz2 templates
db images.html posting.php thanks.html
docs includes privmsg.php viewforum.php
extension.inc index.php profile.php viewonline.php
faq.php language quick_reply.php viewtopic.php
for\ future\ use login.php refer.php
[harpo]$ tar -jxvf phpbb-2.0.11.patch.tar.bz2
tar (child): phpbb-2.0.11.patch.tar.bz2: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
[harpo]$

frustrating. smacks head into desk over and over again


#13

I know… pretty frustrating. Been there…done that.

Do this, check your spelling against the actual file name. You should be typing this: tar -jxvf phpBB-2.0.11-patch.tar.bz2
But it looks like you’ve typed this: tar -jxvf phpbb-2.0.11.patch.tar.bz2

You need to have the dash in there instead of the period right before the word patch.

Hope


#14

Not only did I need the dash but I realized I was typing it in in lower case (phpbb as to phpBB).

It unpacked now. Somebody give me a halleluja! Somebody give me and Amen!! :slight_smile:

Thanks hope…

NOW, lets see if I can get the patch itself installed…

The problem I have here is that my PHPBB directory is basically the root of www.baseballboards.net – so I’m not changing directories here.


#15

Before I open a tar file, I do a dir command, then I select the filename and right click (I use PuTTY) to get the filename correct. Makes it easier but I thought I’d end up confusing you if I tried to explain it. My communication skills get worse as I get older. LOL

Good luck with the patch. It was tricky for me but it finally went through.

Regarding your directory - you’ll probably be able to run the patch command from the same directory.

Hope


#16

Cool hint, Bob, thanks! Feel free to offer more as you see fit. :slight_smile:

And… I prefer to hit the tab - helps me vent… lol

Hope


#17

I’m a freaking IDIOT and those nuts at PHPBB couldn’t tell you the simplest friggin way to install the patch.

Uzing Zip or Tar.bz2 – uncompress the package.

Go to rootdomain.com/yourphpBBinstalldirectory/install/ and run upgrade_to_2011.php

WHY did they make things so difficult having to force people to learn telnet and think of speial methods to apply the patch when the PHPBB directory is the root directory? It boggles the mind!

Baseballboards.net has been upgraded to 2.0.11. ALl Rejoice!

Now I can go back to Grand THeft Auto, San Andreas until the next hacker exploits something that could eventually disrupt a web site of mine :stuck_out_tongue:


#18

LOL! I’m glad you upgraded phpBB successfully!

Hope