PHPBB Installation

apps

#1

Help me. Please. Im so frustrated.
Installation of phpBB 3.0.RC7
Could not connect to the database, see error message below.
Can’t connect to MySQL server on ‘mysql.xorajoken.com’ (4)
ARRRRRRGGGG!
Ok heres the info.
Database Type—
MySQL With MYSQLi Exstensions
or
MySQL

I have tried both with this info.

DSN or Database name mysql.xorajoken.com
Port: 80
I made a database name bbnew
under mysql.xorajoken.com
Made sure it was under my user
Put in my user name: xora
password : ********
And it tell me it can’t connect to the database.

If use the one with MySQLi Exstensions
and te same info I get.
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@forum.xorajoken.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


#2

Any help would be appreciated.


#3

And then I relize I could try MySQL Light.
So i try it and it connects now i go through all of my menus then I get.

General Error
SQL ERROR [ sqlite ]

SQL logic error or missing database [1]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.


#4

[quote]Made sure it was under my user
Put in my user name: xora
password : ******** [/quote]
I’m not sure what you mean by “made it under my user”. MySQL database users are different than your “user” (meaning your general purpose machine user).

You need to make sure you have a user setup for your database, and that you are using that users credentials when connecting to the database.

It sounds very much like you are using a different user than your database use to try to connect.

–rlparker


#5

I knew that and used my MySQL credentials.
Thank you though. :slight_smile:


#6

It could be if you only just created the mysql subdomain that its not become active yet.

Beyond that you seem to have done everything right as far as I can see.

$97 DISCOUNT [color=#CC0000]DISCOM97[/color], Double bandwidth or disk [color=#CC0000]DISCOMX2BW[/color]or [color=#CC0000]DISCOMX2SPACE[/color] (worth $119.40pa). More codes


#7

I think the port 80 could be your issue. You should leave the port field blank.

Port 80 would be for http anyway, and not a MySQL connection, I would think… but I assure you I am no genius of this stuff so could easily be mistaken.

Anyway, re-run the install and leave the port field blank and you’ll probably be good to go.


“Whenever you find yourself on the side of the majority, it’s time to pause and reflect.” - Mark Twain