PHPbb Forum


#1

Hello

This message was recently in the announcements

"Posted: Dec 21st, 2004 - 05:50:29 PM PST (9 days 7 hours ago)

We’ve been getting a lot of support today from people who’ve had their sites “hacked” in the last
24 hours, most of whom are now seeing a page containing “NeverEverNoSanity WebWorm
generation 1” or something similar (the generation number will certainly change for most
people). Most of you seem to be worried that our servers have been hacked or some other
large problem has occurred. This is not the case, however.

If you’d like more information on the worm, zdnet has some decent coverage at http://
news.zdnet.com/2100-1009_22-5499725.html.

This worm spreads via phpBB (using a flaw we first sent an announcement about on Nov. 23), so
please upgrade phpBB as soon as you can (more information can be found at http://
www.phpbb.com/phpBB/viewtopic.php?t=240636).

If you have any data that’s been overwritten by the worm, please do not contact support until
you’ve upgraded your software. Doing so only wastes your time as well as ours, as the worm
will only keep overwriting your files as long as it goes unpatched. Once you have upgraded
your software, we’d be more than happy to help you recover your lost data.

Happy DreamHost Worm-Whacking Team!"

Anyway…

I want to add a phpbb forum to my website and Im just wondering if it is safe to do so now with the above problem. Im very new to DH so I dont really understand. If I download the latest version of PHPbb forum will I be immune from the threat?
Thanks for your time.


#2

Yes, hence this passage:

“This worm spreads via phpBB (using a flaw we first sent an announcement about on Nov. 23), so please upgrade phpBB as soon as you can (more information can be found at http://www.phpbb.com/phpBB/viewtopic.php?t=240636).”


MacManX.com