phpAdmin updated:Now you can not import to DB


#1

Around the middle of 4/4/06 DH “upgraded” their phpAdmin interface to the mysql database setup.

BEFORE the upgrade I could easily upload and import data into my DB tables. Everything worked as long as the file was less than the stated 10,240 kbyte size.

AFTER the upgrade this is no longer the case. The upload chokes after entry 2731 of the file being imported. If I crop off the top 2731 lines and try again it again chokes out at 2731.

I have been emailing back and forth with DH for 2 weeks now and they are in complete denial. First they deny supporting CSV lists ( comma separated value ). Whereas the option to select CSV as an upload option is CLEARLY there on the webpanel form !

So after being told they do not support a feature they expose on their webpanel FINALLY the tech decides…"well MAYBE something is amiss… " But still no timely answer.

So in the mean while I gin up a *.SQL file to test import. This process chokes with a file of 1.6 Mbytes. No where near their limit stated of 10.24 Mbytes.

While there are supposed to be command line options to accomplish the same thing when I tried following the instructions in the WIKI I get null results. Nothing happens. So then I email support AGAIN and ask what about. They offer to do and it works. They email a different method back than what the WIKI states. The tool I used was the built in windows XP telnet program.

Now I can not seem to get these support guys to get out of denial and actually work the issues so I am posting with the hope that others will complain OR tell me where I am making a bonehead mistake !

However the chances of it being ALL me is very low. REASON ? because the exact same files I could upload BEFORE the phpAdmin change would not work AFTER !


#2

What version on PhpMyAdmin is installed on your server (It won’t do us any good to test our installations if they are not the same as yours ;-). It would also help narrow things down if you could tell us which server you are on?

Hey DH “wizards” out there…This could be a hugh problem for all of us. Unfortunately, thanks to a “needy” client and a close deadline, I can’t stop what I’m doing right now and run the necessary tests to confirm or deny this behavior (and probably won’t get a chance to until late this weekend or early next week!), but we all need this functionality.

So, please consider this a “community plea” asking for others to jump in and help.

If anyone out there can look into duplicating this behavior, it would be to all our benefit.

–rlparker