PHP5 path help needed


#1

I will try not to be too long winded here, but I have been frustrated with this for too long now. I am running php-nuke on my site, and I want to add in a genealogy program as a module. The genealogy program works fine in PHP4, but php-nuke needs PHP5 (otherwise I get “access denied” in the admin panel), so I figure I would just upgrade to PHP5. Seems like a simple fix.

The genealogy programmer advised me that I need to have this value: register_long_arrays = On in my php.ini file. DH Support pointed me in the direction of http://wiki.dreamhost.com/index.php/Installing_PHP5. I followed each step. If I use the .htaccess info it suggests, I get this response:
[i]Not Found
The requested URL /cgi-bin/main/php.cgi/main/modules/Genealogy/admin/phpinfo.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
[/i]

I went into my php.ini file, verified that the register_long_arrays=on was correct there…yet if I pull up a info file to show my php settings it shows register_long_arrays=off. This can be viewed here: http://www.seychew.com/main/modules/Genealogy/admin/index.php .

I have a feeling that somewhere along the line I probably don’t have a path pointing to the correct location. I’m fairly new to php so after days…er more like weeks…of trying to get this to work, I’m just feeling frustrated and clueless and would appreciate a fresh set of minds on this if possible.

Thanks in advance if anyone can help me figure this out.


#2

Sorry, I just realized my second link was wrong. The link to show my php info is: http://www.seychew.com/main/modules/Genealogy/admin/phpinfo.php


#3

Not sure if this will work.
Find the global file for phpnuke (it’s probably called common.php or global.php). If you open any phpnuke page in a text editor, look for lines with “require” or “include” (without quotes). These will hint at which file is the global file(s).

Then add

or

That should try to set the variable at run time to on.

To make it a more long term solution, you would probably have to recompile php.ini with the value explicitly defined.