PHP5 option selected. PHP4 running


#1

I’m probably just doing something wrong, but in my control panel, I have selected PHP5 and when I type ‘php -v’ I am running PHP/4.4.4. What am I doing wrong? It seems I am running PHP5 for cgi scripts, but PHP4 from the shell. I need to be able to run php scripts from the shell as PHP5.


#2

Both PHP4 and PHP5 are available from the shell, but only PHP4 is in your default shell path.

You can use PHP5 from the shell by specifying the full path to the PHP executable, for example;

/usr/local/php5/bin/php -v

Mark


Save [color=#CC0000]$50[/color] on DreamHost plans using [color=#CC0000]PRICESLASH[/color] promo code (Click for DreamHost promo code details)


#3

lolz, thanks, ive been searching for it for the past 5 minutes. Thanks for the help.


#4

No problem, I am glad to help where I can. :slight_smile:

Mark


Save [color=#CC0000]$50[/color] on DreamHost plans using [color=#CC0000]PRICESLASH[/color] promo code (Click for DreamHost promo code details)