PHP5 Not Being Seen Internally

software development

#1

Hello DHosters!

I’m trying to install symfony using pear but pear will not install symfony beacuse symfony requires php5.

Here’s what I’ve done:

  1. Set my site domain php version to php5 a few weeks ago

  2. Also compiled my own php5 which is now here:
    /home/myhomedir/php5/bin/php

  3. Added a .htaccess file inside my sites’ root directory that I tried with this: (I also tried the commented out ones as well)

AddHandler phpFive .php
Action phpFive /cgi-bin/php.cgi
#Action phpFive /dh/cgi-system/php5.cgi
#Action phpFive /home/myhomedir/php5/bin/php

  1. From inside my sites’ web directory, I ran php -v,
    which came up with php4 (this is what I’m trying to fix; I need this to be php5)

  2. Ran phpinfo() from same directory and got php5

So, I have potentially 2 builds of php5 available to me but I cannot get any internal programs (pear install symfony/symfony) to
locate php5

Can anyone help me out with this


#2

Thanks for the info. I get that part of it but what I don’t understand is how to get external programs (pear) to see that I’m hooked into php5 and not 4. The problem is that PEAR will not install the Symfony package because it requires php5 and PEAR is seeing php4

Any thoughts?


#3

Thanks, that was what I was looking for.