Php5-cgi reference in .htaccess breaks site


#1

I have a plugin for my site that needs to be able to use ‘allow_url_fopen’. Dreamhost disallows this, so I set up a php.ini file as described on the dreamhost wiki http://wiki.dreamhost.com/PHP.ini.

When I uncomment ‘Action php5-cgi /cgi-bin/php-wrapper.cgi’ in my .htaccess file, the Joomla site throws a 500 error.

Any ideas what I missed?


Clark


#2

Only the most important one: Don’t use anything that requires url_fopen :wink:

Whatever plugin it is, whatever function it performs, there’ll be a much safer one out there. Give the guys here an idea of what the plugin does and someone will likely have a far more secure solution. There’s quite a few blokes here who can take one look at a plugin and recode it directly in a reply on this board.

Maximum Cash Discount on any plan with MAXCASH


#3

Its the Joomla Updater at http://www.intellispire.com/web/page/comupdater.html

The author is updating it to enable use of cURL, instead. Thanks for taking the time to answer, though.


Clark


#4

Yeah cURL rocks! :slight_smile:

Maximum Cash Discount on any plan with MAXCASH