Php4 or 5?


#1

Previously we set our website to PHP4. We run DRUPAL on it. Now I want to install a module (activecollab) that requires PHP5. What are the consequences of switching?


#2

The principal differences involve the default settings for:

Resgister_globals
magic_quotes_gpc
MySQLi useage

There may be (probably are!) others, but those are the issues that generally surface.

You can check out the default installations settings by visiting php.dreamhosters.com, where you can see phpinfo() outputs for various configurations, and find additional information on PHP and MySQL on Dreamhost. Good Luck! :slight_smile:

–rlparker


#3

It might depend on what version of Drupal you’re using. The Drupal site says that version 4.6 supports PHP 5.

If you follow that link, it gives you a list of things to check for.


:stuck_out_tongue: Save up to $96 at Dreamhost with ALMOST97 promo code (I get $1).
Or save $97 with THEFULL97.