Php


#1

How can I confirm these settings on the server?

To run these are the things that your hosting provider will need:

  1.   A Web Hosting account configuration of:
    

a. Is the Linux based operating system

b. Server API is Apache or CGI

c. Sockets Enabled

d. Allow_url_fopen = On

e. Session Support = Enabled

f. Safe_mode = Off


#2

Allow_url_fopen is off and Safe_mode is on (the way they should be for shared hosting), so at least those two requirements are not met. i’m not sure what exactly “sockets enabled” means, but i know the rest of them are met.

track7 - my dream-hosted site


#3

Actually, while you are correct about allow_url_fopen being “off”, safe mode is also off, not on. :wink:

–rlparker


#4

Can these settings be adjusted through the control panel or Dreamhost admin?


#5

Nope, though they can be adjusted by compiling your own version of PHP (instructions available on the DH wiki).

One note of caution:

allow_url_fopen is set to “off” for a very good reason, and unless you really know what you are doing you should not be changing that to “on” on a shared server for security reasons.

If a script is requiring that setting to be on, you should contact the author of that script and inquire as to him rewriting any functions he is using that rely on all_url_fopen to use curl instead.

–rlparker


#6

i know i’ve had errors that said they were due to safe mode, so i assumed it was on – of course i was using the php4 apache module then, so maybe that makes a difference.

track7 - my dream-hosted site


#7

Hmmmm…my phpinfo() on the PHP4 mod_php (apache) shows safe mode as off, as does the "php.dreamhosters.com" phpinfo.

That said, I know what you mean about the errors…many of them are commonly associated with safe mode being on, though they can actually occur in other environments (just not as commonly). The most obvious examples being basedir restrictions and exec errors. :wink:

–rlparker


#8

It is probably worth noting that “safe mode” will not exist in the forthcoming PHP6.


si-blog | Keystone Websites
Save $97 on yearly plans with promo code [color=#CC0000]SCJESSEY97[/color]


#9

now that i think about it, it actually said open_basedir restriction was the problem (which is odd as i was trying to access a file under my document root). so who knows where i got that safe mode idea from :slight_smile:

track7 - my dream-hosted site