Php upload limit - [almost got it... help please]

software development

#1

I’m working on a site with joomla and I’m trying to permit registered users [friends/family] to upload home videos through the front end of my site. I’m wanting to do this with the remository component that is available for joomla.

Anyways, I’ve run into problems with the 7mb limit placed on php uploads by DH.

I’ve searched around the forums and saw several suggestions saying that it should be possible to bypass this limit by compiling php4 on my webspace. So, that is what I did last night following the instructions for ssh access and php4 installation in the wiki.
[btw - why is my main user account unable to login by ssh even after enabling ssh on that user? I had to create a new user to accomplish it…]

Then, I located the php.ini file [at /php/etc/php4/php.ini] and changed line 373 to:
post_max_size = 50M
and line 489 to:
upload_max_filesize = 50M

I was hoping that would solve my problem, but it hasnt. I still have a 7mb filesize limit on php uploads.
From the brief description of my problem, have I done anything totally wrong? [can provide more detail if necessary]

I really don’t know the first thing about php, or ssh, or if I have to have anything in a .htaccess file so please provide detailed answers/suggestions with that in mind. This is the first time I’ve compiled a script so I’m very new to everything.

Thanks in advance,


#2

Have you changed your .htaccess file as it said in the wiki?

I don’t know why your main account can’t connect via ssh. I didn’t have a problem when I enabled it on my account so I can’t help you there :-/

The Insane Cabbit
Blog: http://www.sounanda.com
Store: http://www.marciesgifts.com
PM for CMS or forum install.
[color=#CC0000]$97 Off[/color] with promo code pixiedust


#3

oh, yes I did, forgot to mention that.

As stated, I have no clue about what is really meant to be in my .htaccess file. As of right now it reads as follows:

AddHandler phpFour .php
Action phpFour /cgi-bin/php.cgi

That’s it.
It’s located in my root directory.


#4

There is also a limit on how long a script can take to upload. I’ve not ever tried increasing the limits but you may want to try increasing the max_execution_time and max_input_time and see if that works.

The Insane Cabbit
Blog: http://www.sounanda.com
Store: http://www.marciesgifts.com
PM for CMS or forum install.
[color=#CC0000]$97 Off[/color] with promo code pixiedust


#5

I will give that a shot as well - however I’m dead certain of the fact that it is the upload limit that is causing difficulty for me [well, my lack of knowledge is certainly a problem, too].

I have the docman and remository components installed in joomla [I was testing both out to see which I’d prefer to use]. When I attempt to increase the maximum upload size to anything greater than 7mb through either of those components I receive a notice saying that the settings have been saved, but the php upload limit [as imposed by DH] remains 7mb.

Guess I’ll just have to keep plugging away at it…


#6

[quote]It’s located in my root directory.

[/quote]

When you say root, do you mean it’s in the example.com directory? Isn’t that where it’s supposed to be?

-Matttail


#7

[quote]AddHandler phpFour .php
Action phpFour /cgi-bin/php.cgi

[/quote]

Maybe try this?
Action phpFour /home/username/…/cgi-bin/php.cgi
I.e. specify full path. It also helps to look at error logs