PHP Upgrade Checker Bot


#1

DreamHost should add a PHP upgrade compatibility checker bot. DreamHost is making everyone upgrade to PHP 7.2, which I can understand, but they should implement some tools that make it easier to do. This bot should scan your site to make sure it uses no deprecated functions. I updated my site, and it worked fine, except for saving levels. Which I did not test. It used a deprecated $_SERVER variable and stopped working on 7.2. It would be nice if a bot scanned the files before upgrading.

Thanks!


#2

For others who get caught in this predicament, here are some useful links:

  1. https://www.php.net/manual/en/migration72.php (Also includes migrations guides for earlier versions of PHP)

  2. https://www.php.net/releases/7_2_0.php 7.2 release announcement

  3. https://www.php.net/ChangeLog-7.php PHP change log

There’s also a helpful PHP validator here: https://phpcodechecker.com/

I haven’t had a chance to test it out though.

Seems like only yesterday I was working with version 4. Whew!