PHP Timeout Problem


#1

I am getting processing errors on a program I’ve installed on my site (CiviCRM). After posting my difficulties to their user forum, a couple of expert users wrote back that my server’s PHP maximum execution time is set too low.

I am a newbie. I barely know what PHP is, much less how to extend the maximum execution time.

Where would I access this control? How would I do it?

Any suggestions will be deeply, deeply appreciated. Ones that work will be rejoiced!


#2

Go through the following wiki instructions to increase max_execution_time. You’ll get a .ini file where you can make the change.

http://wiki.dreamhost.com/PHP.ini

-Scott


#3

Thanks…I’m still not clear on one thing.

Ok, so I go to the Unix shell and type in all those lines of code. I’ll try it. Still, that leaves me with a rather stupid question…how do “go to” the Unix Shell? Can I reach it through the Dreamhost panel?


#4

Putty, which uses SSH:
http://wiki.dreamhost.com/Putty
http://wiki.dreamhost.com/SSH

Or Terminal on the Mac.

-Scott


#5

Dear Scott (or anyone who can help)–

I finally managed to get PuTTY to log in (I used these instructions-http://wiki.dreamhost.com/Enabling_Shell_Access--to set up a new account, then logged in, filling in the url on the Dreamhost activation email and the settings recommended in the above wiki from Dreamhost).

So, I’m logged in somewhere or other on the host computer. With that, I plowed into the script at http://wiki.dreamhost.com/PHP.ini

I typed out: mkdir $HOME/mywebsitename.org/cgi-bin

the response from PuTTY was “no such file or directory”

Then I tried: mkdir $HOME/www.mywebsitename.org/cgi-bin

the response from PuTTY was again “no such file or directory”

I’m missing something here…what’s wrong?

Thanks!

Mary


#6

Some shells don’t know what $HOME is. Instead, use the tilde: ~
mkdir ~/mywebsitename.org/cgi-bin

-Scott