PHP Session on Drupal


#1

Anyone running a Drupal site? Do you not have an issue with the Dreamhost PHP settings? I contacted the customer service at Dreamhost and this is the answer I got. I can’t belive I really have to compile my own php scripts:

[quote]If have a problem with following php settings:
session.use_only_cookies Off Off
session.use_trans_sid On On

It should be the opposite, like this:
session.use_only_cookies On Off
session.use_trans_sid Off On

I edited the php.ini file to change the setting:
session.use_trans_sid=0
session.use_only_cookies=1

Also I tried to add this to .htaccess:
php_value session.use_trans_sid 0
php_value session.use_only_cookies 1

But still can’t override the default settings.

It’s very important because I’m getting page not found messages on my
site because of this setting.

[/quote]

Answer:
Unfortunately we cannot change these settings for you in our global configuration files. If you need to have these settings you will have to compile PHP yourself, here are some instructions to get you going:

https://panel.dreamhost.com/kbase/index.cgi?area=2538


#2

Apparently Dreamhost IS using PHP SuExec:
http://wiki.dreamhost.com/index.php/Suexec

So php.ini trick should work. But it doesn’t! Why?


#3

We are running suexec, but that doesn’t have anything specifically to do with PHP (it affects all CGI). There is also something similar called suPHP, but we’re not running that.

  • Dallas
  • DreamHost Head Honcho/Founder