PHP nuke error- no input file specified error

apps

#1

I have installed PHPnuke 7.8. It appears dreamhost is running PHP 4.3.10 (cgi)

I have used ConnectTest.php and all is well with MySQL db and it connects fine.

I have used analyze.php and all is well (except it wants my host to run some security patches which is beyond my control)
When I attempt to set up the application using admin.php I get the no input file specified error.

I think this may be because it is CGI as PHP, although I am not terribly clear on this concept.

To make things more complex when I run admin.php from a command prompt using the -r argument it tells me -r does not exist. When I use php -s admin.php it fills the screen with lots of html…(snipped below)

file_exists(< nt color="#CC0000">"modules/$row[title]/admin/index.php") AND file_exists"modules/$row[title]/admin/links.php") AND file_exists("modules/$row[title]/admin/case.php"< r /> &n p; include("modules/$row[title]/ r /> switch($op ?>; break;/

which would seem to show that it is actually executing admin.php but not sending the output to the browser. Quite perplexing.

Anyone have any thoughts.


#2

I found that everyone should stay away from Php-nuke 7.7 and 7.8 way too many security problems. I tried to upgrade and almost lost all my setting. So I’m staying with php-Nuke 7.6 patch 3.0.

See this post on http://www.64bit.com

http://64bit.us/article83--0-0.html


#3

I think that no imput file specified error doesn’t have anything to see with nuke…

You’re using PHP as CGI, so you should read:
https://panel.dreamhost.com/kbase/?area=2933

This error is producing when someone writes a URI that doesn’t exist, I mean 404 error.


No Setup Programs (in spannish, yes… I’m from Spain)