Php.ini upload_max_filesize (locked?) bug


#1

Hi,

Any help on this would be most appreciated.

I know this isn’t supported, but I carried out the instructions for creating a local php.ini as here:
http://wiki.dreamhost.com/index.php/PHP.ini

I’m running php 5.2.6. The instructions ran fine, and I’ve got a local editable php.ini. However, I’m encountering a bug.

In the new php.ini I’ve changed the post_max_size, and the upload_max_filesize. Post_max_size changes without a problem (once I save in vi, a phpinfo() request responds with the new size, and the online application also registers the change). However, upload_max_filesize seems to be locked at 2M, it will not change. (php.ini has the new size listed after the save, but the server doesn’t register the change).

.htaccess for that folder doesn’t have anything that would cause it. (So nothing there that I can see over-riding the php.ini information). I’ve tried lowering the limit > 2M in php.ini, as well as raising it, to see if it was set as an upper limit. But it stays at 2M in both cases. I can’t figure out if any other setting would have this locked at 2M. :confused:

Has anyone else come across this issue, (upload_max_filesize is locked (at 2M))?

I’m willing to accept that the answer is just under my nose, and my own muppetry is stopping me from seeing it. But where! :slight_smile:


#2

To me the strange thing about what you are reporting is that the default PHP installation on DreamHost shared servers has the max_upload_filesize set to 7MB and the post_max_size set to 8M. Have you tried disabling your new installation in .htaccess and then running phpinfo() against the default install on your server?

I’d be interested in what that shows, and the results ought to at least indicate whether what you are seeing is the result of your php.ini or something else.

–rlparker
–DreamHost Tech Support


#3

thanks for the reply, and you are right, the issue is at my end. When I disable the htaccess pointing to the new php.ini (so that it returns to the default) it returns to 7M. When I enable the .htaccess, the new settings for post size take effect, but the upload_max_filesize reduces down to 2M. If the php.ini was corrupted, I assume that none of the settings would work?

I’ll run the bash script again using a different value for upload_max_filesize, to refresh the php.ini from the default copy. (–Just completed, the new u_m_f is registered in php.ini, but phpinfo() still 2M)

Is there anything on the control panel which can affect this setting?

The only other thing I can think of, (out of mislaid settings) is that my account is up for renewal (not delinquent! :slight_smile: ). Is the upload_max_size throttled until the account gets paid up? (But then surely that would remain throttled on both settings).

Many thanks again.


#4

Just edit your custom php.ini via ftp :wink:

Maximum Cash Discount on any plan with MAXCASH