Php.ini upload limit

wordpress

#1

I have recently begun developing a website using the WordPress platform. I set up a new domain and installed WordPress, everything was working fine.

However, uploading files over 7MB in WordPress results in a error, stating that the filesize is too big. Having investigated this, I followed the tutorial posted in the Dreamhost wiki for creating a custom php.ini file and increasing the maximum upload size.

I followed every step, and installed the new version of php in /cgi-bin/ in my FTP root, as a Dreamhost support advisor recommended, yet I’m still unable to upload files over 7MB.

Having contacted support a few times, they are unable to offer any further assistance on this, and I was wondering if I could find some support here.


#2

In the php ini file you need to chage two settings.
post_max_size
and
upload_max_filesize

Silk

My website


#3

The new php.ini is configured to 100MB, as detailed here


#4

Interesting… I see they updated the information again. Been awhile since I looked at it.
Did you test it and make sure you are using your version and not DH’s version.

My website


#5

Hmm, having checked my phpinfo, it would appear that this is the path the .ini being used

/etc/php5/cgi/php.ini


#6

Double-check that you have .htaccess just like the wiki says.

-Scott


#7

Yep, I definitely have .htaccess


#8

FTP root is your home directory. The /cgi-bin/ belongs in your website folder. If this isn’t the problem, then recheck the wiki instructions or get a fresh set of eyes to poke around. I take it that the phpinfo you mentioned is in a .php file on your website?

-Scott


#9

An advisor from Dreamhost said that I should put it in my FTP root.

I followed the instructions on the Wiki and installed it in my website folder before contacting Dreamhost.

So I have installed it both in my website folder, and my home directory, with no success.