Php.ini upload limit

software development



I am using SlideShowPro Director on a client’s website, but the problem is that I can’t upload videos more than 7mb. The help topic said to contact the host, or edit the php.ini file. Well Dreamhost doesn’t support custom php and I have no idea where php.ini is. They directed me to the wiki pages for setting up the PHP installation, but it is too advanced for me to understand. I am a designer, not a developer (I am learning though).

I’ll send anyone $20 via paypal if they simply help me setup this PHP thing and modify the php.ini so that I can upload files more than 7mb PLEEEAAASE!! It looks so easy but I don’t know how to go on about doing it.



Actually if you go to the wiki and follow the instruction for creating a cgi-bin and making your own php.ini via php.cgi it works just fine and then you can edit your php.ini file.

Where’s my $20?? ;=}


Ok, so I am looking at this wiki , and I have created a cgi-bin, and put in a php file with this code:

CGIFILE="$HOME/[your website directory]/cgi-bin/php.cgi"
INIFILE="$HOME/[your website directory]/cgi-bin/php.ini"
rsync -a /dh/cgi-system/php5.cgi “$CGIFILE”


cp /etc/php5/cgi/php.ini “$INIFILE”

perl -p -i -e ‘
s/.post_max_size./post_max_size = 100M/;
s/.upload_max_filesize./upload_max_filesize = 100M/;

and the next step is where I get lost. I am not sure how to prepare the script for execution by sending command (chmod +x into the shell. Do I do this through an FTP program?


You are all in a twist! ;=}The instructions you were trying to follow were intended to allow you to create a set of shell scripts that would make it easier to manage your custom php.ini.
You indicate you created a php file (??) but included the shall script - note how it starts with #!/bin/sh - and then put that in cgi-bin. GAAAAAA!
You need to have two files in your cgi-bin; php.ini and php.cgi - part of the script’s function is to sync your custom
settings with the dh files (why you delete the stuff after “#Remove…” before using it as an update script…
Pardon me for saying so, but it sounds like you are way out of your depth. The shell is what gives you the little # or > prompt when you telnet or ssh into your server

This is a much simpler explanation for setting up custom php.ini here:
Maybe the alt method would suit you best.
It works flawlessly


hey netbouy, I appreciate your helping me finding out how to get it done. I have used the alternate method and it worked. it was so easy.

Whats your paypal?


As much as I would love to take your money I think my karma would definitely take a nosedive over that. Instead do two things for me: do something nice for someone else and don’t offer cash for help online anymore ;=}


And finally from new user net-buoy

That so completely rocks! It’s that kind of helping that makes these forums such a great community resource. Thanks for making my day, net-buoy! :slight_smile:



I couldn’t agree more.

My website