Php.ini mod on a different domain - gah what am i missing


#1

Hello Everyone,

I have two domains.

One is configured with a custom php build and I am trying to duplicate this on the new domain as well but keep getting 500 internal server errors.

I’ve gone through all the wiki’s and steps but I have to be missing something.

The good domain’s phpinfo() shows the following which i cannot get to appear on my other domain.

Configuration File (php.ini) Path /home/[USER]/php-5.3.4/etc/php5/config
Loaded Configuration File /home/[USER]/[WORKING.COM]/cgi-bin/php.ini
Scan this dir for additional .ini files /home/[USER]/php-5.3.4/etc/php5/config

If I use a specific .htaccess i can get the new domain to open, but not with all of the config. It brings back

Configuration File (php.ini) Path /etc/php5/cgi
Loaded Configuration File /home/[USER]/[FAILING.COM]/cgi-bin/php.ini
Scan this dir for additional .ini files /etc/php5/cgi/ini.d

The additional ini file directory and config path I cannot get to change.
This results in me not having the other packages running on this domain as I want.

Any suggestions on this?

This is the php.ini that brings back the phpinfo

#--- DH-PHP handlers --- AddHandler fastcgi-script fcg fcgi fpl AddHandler php-fastcgi .php Action php-fastcgi /cgi-bin/dispatch.fcgi

This one fails with the 500 error, but this is the one working on the other domain.

[code]#######ADDED BY installPHP script
Options +ExecCGI
AddHandler php-cgi .php
Action php-cgi /cgi-bin/php.cgi

#Deny access to the PHP CGI executable and config files
<FilesMatch “^php5?.(cgi|ini)$”>
Order Deny,Allow
Deny from All
Allow from env=REDIRECT_STATUS

#######ADDED BY installPHP script
Options +ExecCGI
AddHandler php-cgi .php
Action php-cgi /cgi-bin/php.cgi

#Deny access to the PHP CGI executable and config files
<FilesMatch “^php5?.(cgi|ini)$”>
Order Deny,Allow
Deny from All
Allow from env=REDIRECT_STATUS

#######ADDED BY installPHP script
Options +ExecCGI
AddHandler php-cgi .php
Action php-cgi /cgi-bin/php.cgi

#Deny access to the PHP CGI executable and config files
<FilesMatch “^php5?.(cgi|ini)$”>
Order Deny,Allow
Deny from All
Allow from env=REDIRECT_STATUS
[/code]

Feel like i’m bashing my head on a wall… any help would be greatly appreciated!


#2

Lose all the custom PHP stuff — it’s no longer necessary, and you’re running an old, insecure version of PHP with it (5.3.4). Enable PHP 5.3 in the Panel under Manage Domains -> Edit, then follow these instructions to customize your PHP configuration:

http://wiki.dreamhost.com/PHP.ini#PHP_5.3