Php.ini help!

software development

#1

I submitted the following support method and they are “unable to help me” so maybe someone here can.

"> I’ve been following this walkthrough to re-compile my php to increase the

[quote]upload limit. http://wiki.dreamhost.com/PHP.ini

On the part where you enter “chmod +x php-copy.sh”, it doesn’t insert the two
files into the “/cgi-bin/” directory which gives me this error when I’m
completed with the whole tutorial.

"Not Found
The requested URL /cgi-bin/php.cgi/upload/index.php was not found on this
server.

Additionally, a 404 Not Found error was encountered while trying to use an
ErrorDocument to handle the request."

Can you assist me?"

[/quote]

So can anyone help me??


#2

You do understand that this method will not re-compile PHP, right? All this process is designed to do is allow you to modify that single “upload_max_filesize” setting.

That’s because it is not supposed to “insert the two files into the ‘/cgi-bin/’ directory” - that step is accomplished with the next command in the tutorial:

./php-copy.sh

I suggest you start over, read carefully, and follow the instructions precisely - it does work. :wink:

–rlparker


#3

ok I missed a command… but changed my php version to 5.2.2 and it went through and everything… but when I log into my vbulletin admin area, it still says “PHP Maximum Upload Size 7.00 MB” ??? So now what? Did it go through or what?


Nevermind, I was putting it in my /home/ directory… thanks all!!!


#4

Sorry to be the one to tell you, but, “Yeeeeeeeeees … it does work”. If you have done it more then 5 times already, and it still isn’t workikng, then you are doing it wrong. :wink:

Assuming:

  1. that you got the directory made correctly in the previous “mkdir” step, and

  2. created the php-copy.sh script file (using the appropriate one for whether you are modifying a PHP4 or a PHP5 installation - since you are having trouble do not use the "more general script with options, as it will only confuse you),

  3. and executed the “chmod +x php-copy.sh” command to make the shell script you created in step 2 (above) executable *

  4. AND EXECUTED That “php-copy.sh” script by typing “./php-copy.sh” at the shell prompt(without the quote marks and where “” means “and then hitting the key”

Then, and only then, you will not get the "“Not Found -
The requested URL /cgi-bin/php.cgi/upload/index.php was not found on this server.” message.

The fact that you are getting that message is “the strongest evidence” that you are not following the instructions, or are in some other way “doing it wrong”. Doing it wrong repeatedly is not going to make it work any better…

So, at the risk of sounding like a broken record…

  1. Re-read the instructions, and this post, carefully

  2. Do it again, from the beginning.

If you are still not able to get it to work, then post back and report each step that you completed, and what results were shown on the screen after each action, and I’ll try again to help you.

One last time…it works. It was worked for many many others; there is no reason it will not work for you if you do it correctly. If you can’t do it correctly, it will never work.

–rlparker


#5

Oh, Nice! So you edited your post while I was typing a reply (that apparently wasn’t needed). Meh, I’m glad you got it accomplished. :wink:

I don’t use vbulletin, so I do not know where it gets the info to report that information, or if it is a configurable setting in vbulletin. Generally speaking, such things are set by an application at install time by querying the PHP installation, or set by the application dynamically at run-time. If you installed vbulletin before you made the change, it may need to be reset in vbulletin. Then again, as I said, I don’t use vbulletin, so that is only “an edumacted guess” :wink:

[quote]So now what? Did it go through or what?
[/quote]
I have no way to know that, but you can easily check it yourself by running a phpinfo() program, and seeing what is reported.

If it “went through”, the phpinfo() report will show the path to your copy of php.cgi and php.ini (the ones in your cgi-bin directory, not the DH common directories), and will show your new upload_max_filesize value. If those thing are correct in the phpinfo() report, then the remaining problem is somehow related to a vbulletin setting

If you don’t see those changes, then it “didn’t take” and you are still doing something incorrectly. You will then need to “get it right” and repeat the phpinfo() confirmation process I just described to see that it has worked. Only then should you worry about vbulletin.

–rlparker

Edit: Ha! you edited that last post again while I was typing another (again, apparently unneeded) answer… remind me next time to wait at least an hour before responding to your posts … and you’re welcome! :wink: