Php.ini file for my account


#1

I received the error message below when installing Joomla!. Looks like I need to change these settings in my php.ini file for my individual domain. Can anyone guide me on how I need to go about this? Mainly, how or where can I modify the php.ini file for each one of my domains or the whole hosting account?

PHP register_globals setting is ON instead of OFF


#2

You could always try setting your domain to use PHP5, register_globals is off by default under the DreamHost install of PHP5.

Changing php.ini settings is not a simple procedure, as you do not have write access to the php.ini file for your shared server.

There is a procedure described in the wiki for copying the DreamHost installed PHP executable and php.ini file to your domain and configuring things in your .htaccess file so that this local install is used. However, the wiki is currently experiencing problems, so I am unable to provide a link at the moment.

Mark


Save [color=#CC0000]$50[/color] on DreamHost plans using [color=#CC0000]PRICESLASH[/color] promo code (Click for DreamHost promo code details)


#3

k, can’t wait until you get that wiki thing resolved. i’m not reverting to PHP5, so i will wait for the wiki. thx.


#4

Well, I didn’t personally resolve it, but the wiki appears to be back up. :stuck_out_tongue:

Below is a link to the article I was referring to. Note that the procedure is rather involved and should only be attempted if you are reasonably comfortable working in the shell. The scripts in the article automatically change the settings for post_max_size and upload_max_filesize in php.ini, but are easily modified to change whatever setting you are interested in.

http://www.wiki.dreamhost.com/index.php/PHP.ini

Mark


Save [color=#CC0000]$50[/color] on DreamHost plans using [color=#CC0000]PRICESLASH[/color] promo code (Click for DreamHost promo code details)


#5

Since Joomla’s offered as a one-click, I have to assume that even with that setting set to off the system is still usable. Does anyone know what that affects specifically in Joomla? (Yeah, I could go look it up, but I have things to do too.)

Wholly


#6

It will still work fine…there is a little more information about the whole Joomla! PHP4/PHP5 thing on DH in the Discussion Forum post I’ve linked here.

–rlparker


#7

Please see my post in this thread for more detail.


#8

Great coverage there guys! Thanks for the details. That message is a bit disconcerting. DH might to well to add a warning to the one-click email saying that these specific warnings are NOT deadly.

Wholly