Php.ini and upload_max_filesize

software development

#1

So far I’ve read and followed the instructions at: http://wiki.dreamhost.com/PHP.ini, but these continue to return a 500.

I’m using Notepad to create the .htaccess and php-wrapper.fcgi files and when I save them I’m selecting “All files” under ‘Save as type:’ and I’m using ANSI encoding. Is this the right encoding? Should I be using UTF-8? Please help!

I can provide screenshots or even capture of what I’m doing if that helps. All I’m trying to do is increase the upload_max_filesize from 7M to 50M. Any help, links, or suggestions are greatly appreciated.


#2

Don’t use Notepad. It creates files with DOS line endings, which Linux doesn’t appreciate.


#3

Thank you for such a quick reply!

I’ve ditched Notepad, deleted the old files, and re-written them in pico but am getting the same error. Does pico also create files with DOS endings? or will it take the server I’m on time to notice the new php.ini file I’m pointing to?

EDIT Nevermind - it is working now, my phpinfo() page indicates it is looking at the proper php.ini file. BUT, it’s still not letting me upload anything over 7M. I’ve set it to 10M in the php.ini file, but it doesn’t seem to be recognizing that value…

EDIT2 GOT IT! Forced a recache and now it’s operating as it should be. Thank you for turning me off Notepad!! =)


#4

Notepad as ANSI is fine. Wordpad, Word, etc. will cause trouble.

Receiving the same error using pico indicates the problem lay elsewhere :wink:

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost