PHP files not Querying!


#1

Hey! I’ve been trying to install some PHP download scripts lately but when i visit the install page and click install but nothing happens. I finally worked out that the SQL in these scripts isnt executing. I thought i’d give it a try by copying the query out of the php file and inserting it into phpmyadmin myself. It worked fine but then another problem is that i have to login on another page of the script which once again needs SQL access. I cant manually add this so i need help.

Is there anything i can do to get this script working? i know there are download scripts that dont use SQL but i dont want to use one of them. I’ve made sure my SQL details are correct and they are. Anyone know what could be going wrong? My forum works fine so i have no idea :confused:

EDIT: I’ve just tested it on my other host and it worked fine :’( Only differences are:

Other host:
PHP version 4.4.2
MySQL version 4.0.27-standard-log

Dreamhost:
PHP version 5.1.2
MySQL version 5.0.18-standard-log

Could the different version be the cause? Any idea how i could get the script to work on dreamhost?


#2

Ok, dont know why i didnt think of this. Just made a new subdomain called downloads and made it PHP version 4 and it worked fine. Do that if anyone else is as stupid as me :stuck_out_tongue:


#3

Bet you it’s using register_globals.

What download script is it? You sure it’s compatible with PHP5?


yerba# rm -rf /etc
yerba#


#4

The script isnt compatible with PHP 5 so i just changed a subdomain to PHP 4. I’ll have a look to see if its using register_globals because i dont want to keep it in PHP 5. The script is called DownloadPro.