PHP FanBase MySQL

apps

#1

I’m trying to install PHP FanBase to my webpage, and I’m having some troubles. I must be doing something wrong with config.php, because when I load create.php in the browser, it says:

Warning: Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2) in /home/.cacao/reba42/farbeitfromme.com/mintyfresh/config.php on line 54

Warning: MySQL Connection Failed: Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2) in /home/.cacao/reba42/farbeitfromme.com/mintyfresh/config.php on line 54

Warning: MySQL: A link to the server could not be established in /home/.cacao/reba42/farbeitfromme.com/mintyfresh/config.php on line 54
Unable to select database.

When it should say “Success! Tables created!” Config.php asks for the following information: the MYSQL database host (usually “localhost”, the script says), the database name, the MYSQL username, and the MYSQL password. Do hostnames come into this anywhere? Is the database host not localhost, because this is NOT working and I’ve tried everything I can think of. Any help would be greatly appreciated.

Thanks,
Reba


#2

If you didn’t in creating the database you’ll need to create a hostname from the control panel (on the same page you created the database)


#3

I did that, and I guess it took a while for it to become activated, but after a few hours I could get into phpMyAdmin alright. But the script still isn’t working, I’m still getting that error message when I load create.php. Do you have any idea what’s going on?


#4

Are you inputing that hostname when it asks you to? Localhost works on a lot of set-ups, but not Dreamhost’s because the databases are on a seperate database machine(s) here.


#5

I hadn’t been, so I changed it, thanks for telling me about it. But it still doesn’t work, I’m still getting the same error message when I go to create.php. Could it be because my database and my host are named the same thing? I don’t see how that would cause any problems, though. Arrrgh, this is so frustrating, thanks for your help.


#6

Ay caramba! I just put in the hostname as the host, but when I tried putting in hostname.domain.com, as I probably should have in the first place, it appears to be working! I will probably have some more problems, Murphy’s Law and all that, but thank you so much for your help, it was invaluable.


#7

Technically the ‘domain.com’ /is/ part of the hostname not just the part you typed in – but I’m glad you got it working :slight_smile: