PHP Custom Build With GD Library 2.0.33

software development

#1

I really need a later version of the GD Library than the default, and CS linked to this wiki on installing a custom build of PHP 5. Despite being clueless, in desperation I’ve spent the past week trying to get this to build PHP 5 with the more recent version, to no avail. I’ve added the required jpeg and png libraries to that, and I’ve been experimenting with variations of things I see in the script like:

--with-jpeg-dir=${INSTALLDIR} \ --with-png-dir=${INSTALLDIR} \ --with-gd=${INSTALLDIR} \ in the configuration (I have no idea when to use -dir and when not to, but think I have tried all the combinations anyway) but that just throws a bunch of call to undefined function errors, other variations have just done nothing. Would somebody please be kind enough to walk me through this?


#2

don’t forget you need to do a ./configure make and make install also in the php4 or php5 directory.


#3

I’ve been using this, following the pattern of the original script

[code]#libpng
cd ${SRCDIR}/${LIBPNG}
./configure --prefix=${INSTALLDIR}

make clean

make
make install

#libjpg
cd ${SRCDIR}/${LIBJPG}
./configure --prefix=${INSTALLDIR}

make clean

make
make install

#libtt
cd ${SRCDIR}/${LIBTT}
./configure --prefix=${INSTALLDIR}

make clean

make
make install

#gdlib
cd ${SRCDIR}/${GDLIB}
./configure --prefix=${INSTALLDIR}

make clean

make
make install
[/code]everything seems okay (at least as far as I can tell) until PHP 5 goes to install.


#4

It would be most helpful to both of a) us trying to figure out what’s wrong and b) you getting your problem solved if you could include the actual output of error message(s) you’re getting.
Don’t be shy - some good number of us lusers have probably already made the same screw-ups as you have.


#5

You’re right, I’ll try running it again in a little bit and then I’ll post both exactly what I’m trying to use, as ridiculous a hodge-podge as it is, and whatever results seem relevant from putty.


#6

Good news, I deleted all the old directories and ran it over from scratch, and it made it this time. Only thing is I noticed I hadn’t added anything to the PHP config options to enable freetype, so now I have to do it over and get that working too. Thanks for the responses, and I may be back for help on that now, or it might start barfing on me overall yet again lol.


#7

Okay, it would seem everything is in order, but I’m getting an error when I try to use ImageTTFText…
Warning: imagettftext() [function.imagettftext]: Could not find/open font in /home/.patricia
…and so on. The .ttf file is there and it all worked fine before the changes though.

Here is the test from where I get the error: http://dragonflygraphix.com/telemachus/testform.html
Here is what phpinfo reads on the install: http://dragonflygraphix.com/telemachus/phpinfo.php


#8

Nevermind I’ve got it sorted now. :slight_smile:


#9

Just a thought, but maybe you could share your script on the wiki, especially any details of newer versions or additions that was not included in the original script.
That may make it easier for someone else who finds something they would like to add or update. Then hopefully they will share. And so on.
Silk

My website