PHP - Composer Install Issues


#1

I’ve been trying to install Laravel 4. I’ve followed instructions on proper installation up to installing Composer.

Using the command (I am using the proper install directory):

returns:

"[b]Some settings on your machine make Composer unable to work properly.
Make sure that you fix the issues listed below and run this script again:

The phar extension is missing.
Install it or recompile php without --disable-phar[/b]"

I have enabled phar.so in my phprc file for the proper version of php. Using phpinfo() and $ php -i | grep phar will both return with ‘–enable-phar=shared’.

I’ve looked everywhere for help on this and I have yet to find anything that can resolve this issue. Am I missing something?

My php Configure Command:


#2

Did you include BOTH of these lines?

extension = phar.so suhosin.executor.include.whitelist = phar

Then to verify that Phar is installed run

I tried these commands on a site that is using php 5.5 and it worked great.


#3

You don’t need the “suhosin.executor.include.whitelist” line, by the way. We stopped using Suhosin quite some time ago.


#4

I have tried the suhosin line. It did not make a difference regardless if suhosin is still being used.

I went in to copy my 5.6/phprc file a few hours after posting to update my post with more information and found that it was empty. I did not do this… well it now reads:

; {{{ The following lines were automatically added by DreamHost zend_extension=opcache.so ; }}} That's all from DreamHost extension = phar.so

php -m is not listing phar at all and php -i | grep phar is returning the same thing as I posted before.


#5

Did you change the default version of PHP CLI in the shell to be version 5.6?


#6

That was it! Thank you. I should have checked the version shell was using after upgrading to 5.6.