PHP Compile - CURL Fails


#1

I been trying to compile custom php5.2.3 on my private server for a single domain so I can use ionCube Loader.
The main install script from the wiki didn’t work so I used the alternate scripts (last updated in December so should be good).
First curl kept 404ing to download in php5-install-prep.sh. So I manually downloaded/uploaded the packages to the /dist dir. Then, ran the php5-install-prep.sh without the download part in the script. That worked.

Then I ran php5-install.sh and it does all the building. When when it gets to cURL curl-7.17.1 it says:

Building: cURL

Configuring…

Then imediately returns to prompt even though it has more packages to build. Script would echo that it’s done if it was finished.

Darrell
Web Developer
On-Site Computer Solutions


#2

bump?

Darrell
Web Developer
On-Site Computer Solutions


#3

i just tried compiling with 5.2.5 on a PS.

I also had trouble with curl…

what I ended up having to do, is compile manually without using the script.

I had to change the configure options to compile php to add an explicit directory for curl since the configuration script will look elsewhere by default.

./configure --with-curl=/home/yourusername/yourphpinstalldirectory

that directory should have your /lib and /include/curl in it.

I was finally able to successfully compile curl with a “make” and “make install”

following that, I continued to configure, make, make test, and make install

I don’t know if adding an explicit directory to your curl configuration will help

I haven’t gotten my php to work properly but at least curl compiled alright without missing things.

For cUrl, I used ./configure --with-ssl=/home/yourusername/yourphpinstalldirectory --with-zlib=/home/yourusername/yourphpinstalldirectory --with-libidn=/home/yourusername/yourphpinstalldirectory --enable-ipv6 --enable-cookies --enable-crypto-auth --prefix=/home/yourusername/yourphpinstalldirectory