PHP 5.5 Install Broke With Ubuntu Update, Cannot Get It To Work

software development

#1

Hello,

About a month ago, I installed PHP 5.5.17 on some domains to take advantage of the improved password functionality.

It has been working perfectly since then. Suddenly, right around the time of the Ubuntu upgrade, we started getting an internal server error.

Here is the exact error:

"Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@(mydomain) and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

I obliterated the content on one of the domains and placed:

  1. A simple index.html file that outputs “Test”
  2. A file that simply runs phpinfo()

In either case, the html file works.

If I rename the .htaccess file so that the site does not point to PHP 5.5, phpinfo() works, if I do not, it returns the server error.

Again, I have been using PHP 5.5 without issue since I installed it on all three sites…until now.

Aside from the above, narrowing down that it appears to be the PHP 5.5 install, I have done the following:

  1. Tried a simple re-install without obliterating the old folders from the last one - failed
  2. Obliterated the previous install folders and tried a complete download and re-install - failed
  3. Tried #2 again

Note: the current version is now 5.5.18

As I did a month ago, I am following the instructions in the Dreamhost wiki (http://wiki.dreamhost.com/Installing_PHP5#Install_script_for_PHP_5.5.x)

However, I cannot seem to avoid an error at the 100 minutes (or so) mark. Here are the errors (minus my domain paths):

ext/openssl/.libs/xp_ssl.o: In function php_openssl_setup_crypto': undefined reference toSSLv2_server_method’
undefined reference to `SSLv2_client_method’
collect2: ld returned 1 exit status
make: *** [sapi/cli/php] Error 1

Now, I have the old output screen from the last install and there was no mention of openssl in that. So, perhaps that it where the problem lies, given that is where the error seems to have happened.

Searching the interwebs pulls up reports of bugs with this years ago, but nothing recent.

Please help!