Personal Backups and compression


#1

This is probably a silly question. I used rsync to backup about 3.5 GBs of data from my Mac to the backup server. It seems to have worked flawlessly, but when I go to the panel to look at the backup user, it says I’ve used 0.38 GBs.

I used the -z flag when I ran rsync. Does that mean the data is compressed when it’s persisted, or does that mean the data is compressed in transit? I thought it was the latter, but maybe it’s both.

If that’s the case, does this mean I can actually store more than 50 GBs because of the compression? Or does this mean the backup user page is reporting the wrong amount?


#2

Without seeing the entire command, there might be something else wrong. A 90% compression average would surprise me. How big is the backup without the -z flag?


#3

The rsync command was this:

rsync -avz ~/Documents bxxxxxx@backup.dreamhost.com:Godiva-Backup

When I look at my Documents folder on the Mac, it reports about 3.5 GBs.

Do you mean I should run another rsync without -z and see if there’s a difference?

Is there a way via SFTP to see the size of the folder?


#4

The -z flag to rsync only compresses the network traffic. The end result of the rsync is the same with or without it.

The disk usage information shown in the Panel is not a live reading. It can sometimes take up to a week to catch up with uploads, as it takes quite some time for us to sample everyone’s disk usage on that server.


#5

Ah ha! Okay, I just checked again and it now says 3.09 GBs. So I guess I’ll just wait for it to catch up. Thanks!