Permissions changed on my domain


#1

I can’t upload anything to my website because somehow the permissions for that domain have changed. I just worked on this site last week, and wanted to upload some more pages, and it says 550 permission denied.

I wrote to Tech support yesterday, but have not heard back, and I have been waiting all day to upload the my changes.

Since I don’t have the ability to change the permission of my domains like that, I would appreciate it if someone would go in and fix it so I can get back to work.

Thanks


#2

Telnet in and use the chmod command to change the permissions the way you want them. You’re listed as owner of the files and directories, aren’t you?


#3

Well I tried that and it said I didn’t have permission to do that.

I wrote support and they finally got back with me, and said they had re chmoded me back to 755 but I just logged on to ftp and tried to upload files and by golly it is permission denied again. … sigh…


#4

Well here it is Monday Morning and still my problem is here. Something as simple as resetting the permissions on a folder, has to drag out from Friday to Monday.

The person who reset or supposedly reset the permissions, changed something to read 755 but it wasn’t the permissions.

I have written support back and it has been 1 day and 11 hours and still no response.

The whole weekend I planned on working on this site, and could do absolutely nothing.

There needs to be a better way to deal with something like this. I have no problem with writing to support and having the first message take 24 hours or so to get a response, but if they don’t fix the problem and I write back it should have priority, instead of being put back to the end of the line, and making one wait another 24 hrs. This is just unacceptable.


#5

It sounds to me like your FTP client is resetting the permissions when you connect.

Have you tried changing the permissions yourself from an FTP client?


#6

Yes I have tried to change it myself, and I am told permission denied. Tried that the first day. I dought my software is resetting it I am using ws_FTP pro, and never had this problem before.

I have many domains in the same folder of this account. This is the only one that is effected.

I am on my 4th support notice… they wrote me back and said they reset it…again they did not succeed. of course it will be another 24 hours before I get an answer for this one.


#7

It sounds as if the directory was created or modified by a user other than the one you are using for FTP. This could happen if you ran a script over the web when the domain is set to run scripts as a different user than your FTP user. It can also occur if you ran a program from shell access and the shell user is different than your FTP user.

You should be able to make a new directory using FTP and then use the Web Admin Panel to edit the domain settings to point to the new directory instead. Make sure the domain is set to run scripts as the same user you intend to use with FTP. Then just wait for the web server to re-load the configuration.

To get to the appropiate settings in the Web Admin Panel,

  1. Choose the domain in question as the “Active Domain”
  2. Choose “Web” in the “Domains” menu.

Hope this helps.