Permission problem


#1

I’m running a copy of CubeCart version 3.0.17

My site has developed a weird permission problem. I’ve not made any changes for some months and now all the thumbs on the front page refuse to show. http://www.orientbeachstore.com/

Futhermore, when I login to the backend I get a whole series of permission errors. I’m not sure where to start. I’ve tried changing all folders and files to 0775 but no love. Then everything to 0777… but nothing works.

Here’s some screen shots of all the errors on the front page, and when logged into the backend http://shop.orientbeachstore.com/problems/

I uploaded a backup copy to http://shop.orientbeachstore.com/ but still the same problem

Any hint on where to start would be a great help. I’ve posted on the CubeCart forum but no luck so far.

TIA

Kerry


#2

you should check your .htaccess for changes and also if you have one in the upload folder > CHECK THIS, since DH has added .htaccess for security reasons, espescially in upload folders.

If that is all OK, try renaming the original upload and manually create a new one and re-upload all images by FTP


#3

Just a note:
DO NOT modify permissions to 777 EVER. This is a huge security hole.
Folders at most should be 775, files even lower, like 644 or 640 (depends what you’re running, but you can Google for specific permissions for your web app).


#4

Agree with mattesque
still check .htaccess
and let us know your solution so other newbies can learn


#5

Hi folks,

Firstly, thanks for your help.

I have an .htaccess file but there is nothing in it. I uploaded it some years back and have only used it for redirects. I’ve checked all the directories and there is are no other .htaccess files.

I’ve tried every permission possible and nothing works. Very frustrating! I continually get the same permission error.

I have asked the same question over at the Cube Cart forum and they suggested it may have something to do with Dreamhost upgrading the security on the servers?

I was asked the following question by one of the users on the other forum-
“Please confirm if “open_base” security protocols or some other “folder traversal” interdiction has been implemented on that server.”

Can anyone confirm any changes on DH recently?
The link to the thread is at http://tinyurl.com/7alclyz

I do admit CubeCart 3.x.x is old code. But before I try to upgrade I like to know what is causing the problem.

Again, thanks for your help.

Kerry