Perl symbol lookup error


#1

Hey guys. A few of my sites went offline the other day with 500 errors now serving.

When I log into my shell I receive the following error when running various perl scripts, and cpan:

/usr/bin/perl: symbol lookup error: /home/my_user/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/auto/IO/IO.so: undefined symbol: Perl_Tstack_sp_ptr

I run catalyst w/ local::lib, and know neither is officially supported. I’m not looking for help fixing the problem, but rather am wondering what, if anything had changed with the perl installations on dreamhost.

The wiki says 5.8.4 is used, but I suspect that is out of date. perl -v tells me 5.10 is installed.

Were there recent upgrades or anything? I haven’t worked on these sites for nearly a month, so I suspect something changed out from under me that I wasn’t prepared for.

Does anybody have any insight into what may have changed? I am on Jazz, if that helps at all.

Note I can work fine with perl itself if I choose not to use local::lib, but that limits my use of cpan tremendously.

Much thanks!


#2

Same error here. I’d swear the perl used to be 5.8.8, because I often wished for 5.10. I guess I got what I wanted :slight_smile: I’ve submitted a support request asking if the error is because of the new perl and if the 5.10 is going to stay. I also tried to find some info about perl upgrade, but did not find anything.[hr]
Yes, perl was upgraded to 5.10 and is going to stay. Which means we will have to reinstall some modules from the local::lib to get things working again.


#3

Well that makes me feel better. At least I’m not the only one.

I suppose I’ll submit a support request/question (requestion?) too. I can’t expect too much help with stuff I’m using that isn’t supported, but a little bit of info would help.

On that note, zoul, in what way did you notice that something was different? Did you have perl-powered sites running as well that went kaput or was there some other symptom?


#4

Yep, all my Catalyst websites went down. I’ve deleted my ~/perl5 directory and reinstalled the modules, now everything works again.


#5

cool, just did the same and it works fine. was kind of afraid to touch anything at first.

thanks for the tip