Perl Problem


So I am trying to use an online quiz created with QuizFaber ( that uses two Perl scripts to store test results. I have the Perl files ( and in cgi-bin under my folder on DreamHosts webFTP. I had to modify the first two lines of each Perl file with my websites information:

If you have a Linux/Unix web server, type at the command line:
which perl
You should see something like:
This is the path to your perl interpreter. So you should change the first line of perl script (for each script) as follow:
In order to know the path of your home directory, type at the command line, just after login:
You should see something like:
This is called ‘Home Directory’. From this directory, you can choose a (new or existing) directory where create your archive file.
If you decide to store archive file in your home directory, you should change the second line (for each script) of Perl script as follow:
$file_path = ‘/usr/local/vhosts/’;

So my Perl look like this…

$file_path = ‘/home/myaccount/’;

$file_path = ‘/home/myaccount/’;
$image_path = ‘’;

Once the quiz in done, it tries to write to results.log in the folder, but I get the following error:

[i]Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.[/i]

I’ve set the permissions for both Perl scripts to:
User: r w x
Group: r w
All: r w

Any Ideas? Thanks in advance!


so, um, what does the error log (~/logs/ have to say? it should give you more information.


Try setting the file execute permissions: if group id of file is the same as the id of the apache server #1 may suffice else do #2

  1. chmod g+x and

  2. chmod go+x and
    sorry, remove the ‘and’ from the two commandlines above :-/
    you can also try:

perl -c

perl -c

both should yield:

{filename} syntax OK