Perl Modules in the wrong place

apps

#1

I followed the directions from the wiki, and I tried to install a Perl module just like it said.

For some reason it installed to .cpan instead of the perlmodules directory.

I tried to start over, and it would not work.

I also submitted this to support, and it is the first time I was not given ANY support whatsoever, I was just given this url to come here and pray someone knows wtf I am talking about.

Any suggestions?


#2

It would help if you gave us the link to the page n the wiki that you followed.

That “reason” has to have something to do with your installation. There is always a reason, though the reason may not be readily apparent. Often a very small typo or misunderstanding of a command’s syntax can produce unexpected results. Again, point us to the wiki page you used so we can have a better idea of how to help.

Yeah, such an issue is not likely to be something you can reasonably expect tech support to help you with - it’s purely a programming/scripting issue that is not related to the proper operation of the Dreamhost services. They often will go the “extra mile” if it happens to be something particularly related to some unique aspect of the Dreamhost setup, but generally speaking, these are not the kinds of things that tech support should be expected to handle for these types of accounts.

If you provide more details, however, some of the folks here might can help. :wink:

–rlparker


#3

The wiki page
http://wiki.dreamhost.com/index.php/CPAN

The reason that I went to them first is simply that the Dreamhost servers have a specific setup for their Perl Modules, that requires their users to load them differently than would normally be done. My assumption was that they would be able to help me figure out the reason why, or at least point me in the right direction for why this loaded the way that it did, when i used their system that they set up weirdly. (Although, I do understand why it was set up this way, which is security, and to make sure I don’t screw up someone else’s virtual server while I am screwing up my own!)


#4

From looking at your first post, and reviewing the CPAN wiki page I suspect that the result you encountered is the result of the commands in one of these two sections of the wiki article:

  1. Perl needs to know where the new modules are going to be installed:

$ PERL5LIB=/home/username/perlmods/lib/perl:/home/username/perlmods/lib/perl/5.8:/home/username/perlmods/lib/perl/5.8.4:
$ PERL5LIB=$PERL5LIB:/home/username/perlmods/share/perl/5.8:/home/username/perlmods/share/perl/5.8.4:
$ export PERL5LIB

  1. $ perl -MCPAN -e shell

Are you ready for manual configuration? yes

Policy on building prerequisites (follow, ask or ignore)? follow

Parameters for the ‘perl Makefile.PL’ command? Typical frequently used settings:

PREFIX=~/perl non-root users (please see manual for more hints)

Your choice: PREFIX=~/perlmods


I suspect that one of those command lines may have been mis-typed, omitted, or entered with an incorrect path, but of course, I don’t know for sure.

I suggest you delete all the created directories/files from your failed attempt, and try it again with special attention to the above section values. The methodology as described does work, though it can be tricky.

Additionally, make sure that the module you are trying to install is not already part of the Perl installation at DH, and that you completed the “use lib ‘/home/username/perlmods/share/perl/5.8.4/’;” step.

What module(s) are you trying to install?

–rlparker