PECL uploadprogress (PHP Version Error)


#1

I followed the insturctions here, and installed custom PEAR, to beable to install packages.

It seems to work fine and take over for PECL to.

When tyring to run “pecl install uploadprogress-beta”

I recive this error

pecl/uploadprogress requires PHP (version >= 5.2.0), installed version is 4.4.7
No valid packages found
install failed

In panel I do have php version as 5.2.2 for all my sites

This is config for pear
pear config-show
Configuration (channel pear.php.net):

Auto-discover new Channels auto_discover
Default Channel default_channel pear.php.net
HTTP Proxy Server Address http_proxy
PEAR server [DEPRECATED] master_server pear.php.net
Default Channel Mirror preferred_mirror pear.php.net
Remote Configuration File remote_config
PEAR executables directory bin_dir /home/kilandor/pear
PEAR documentation directory doc_dir /home/kilandor/pear/docs
PHP extension directory ext_dir /home/kilandor/pear/ext
PEAR directory php_dir /home/kilandor/pear/php
PEAR Installer cache directory cache_dir /home/kilandor/pear/cache
PEAR data directory data_dir /home/kilandor/pear/data
PEAR Installer download download_dir /tmp/pear/cache
directory
PHP CLI/CGI binary php_bin /usr/local/bin/php
php.ini location php_ini
PEAR Installer temp directory temp_dir /tmp/pear/temp
PEAR test directory test_dir /home/kilandor/pear/tests
Cache TimeToLive cache_ttl 3600
Preferred Package State preferred_state stable
Unix file mask umask 22
Debug Log Level verbose 1
PEAR password (for password
maintainers)
Signature Handling Program sig_bin /usr/bin/gpg
Signature Key Directory sig_keydir /usr/local/etc/pearkeys
Signature Key Id sig_keyid
Package Signature Type sig_type gpg
PEAR username (for username
maintainers)
User Configuration File Filename /home/kilandor/.pearrc
System Configuration File Filename /usr/local/etc/pear.conf

This is config for PECL
pecl config-show
Configuration (channel pecl.php.net):

Auto-discover new Channels auto_discover
Default Channel default_channel pecl.php.net
HTTP Proxy Server Address http_proxy
PEAR server [DEPRECATED] master_server pear.php.net
Default Channel Mirror preferred_mirror pecl.php.net
Remote Configuration File remote_config
PEAR executables directory bin_dir /home/kilandor/pear
PEAR documentation directory doc_dir /home/kilandor/pear/docs
PHP extension directory ext_dir /home/kilandor/pear/ext
PEAR directory php_dir /home/kilandor/pear/php
PEAR Installer cache directory cache_dir /home/kilandor/pear/cache
PEAR data directory data_dir /home/kilandor/pear/data
PEAR Installer download download_dir /tmp/pear/cache
directory
PHP CLI/CGI binary php_bin /usr/local/bin/php
php.ini location php_ini
PEAR Installer temp directory temp_dir /tmp/pear/temp
PEAR test directory test_dir /home/kilandor/pear/tests
Cache TimeToLive cache_ttl 3600
Preferred Package State preferred_state stable
Unix file mask umask 22
Debug Log Level verbose 1
PEAR password (for password
maintainers)
Signature Handling Program sig_bin /usr/bin/gpg
Signature Key Directory sig_keydir /usr/local/etc/pearkeys
Signature Key Id sig_keyid
Package Signature Type sig_type gpg
PEAR username (for username
maintainers)
User Configuration File Filename /home/kilandor/.pearrc
System Configuration File Filename /usr/local/etc/pear.conf

I seen in other post long ago about this, about doing the installingphp5, but i’m using PHP5, so I shouldn’t have to install it custom? I should beable to use DH’s PHP5 Somehow but I dunno how.

Can anyone help please?

Seditio Forge - CMS User ran site
FFXI Mod Communtiy


#2

I think whats hanging you up is your path to the PHP-CGI binary on both config files is pointing to the PHP4.4.7 PHP-CGI (see in [color=#CC0000]red[/color] below:

This is config for pear
pear config-show
Configuration (channel pear.php.net):

Auto-discover new Channels auto_discover
Default Channel default_channel pear.php.net
HTTP Proxy Server Address http_proxy
PEAR server [DEPRECATED] master_server pear.php.net
Default Channel Mirror preferred_mirror pear.php.net
Remote Configuration File remote_config
PEAR executables directory bin_dir /home/kilandor/pear
PEAR documentation directory doc_dir /home/kilandor/pear/docs
PHP extension directory ext_dir /home/kilandor/pear/ext
PEAR directory php_dir /home/kilandor/pear/php
PEAR Installer cache directory cache_dir /home/kilandor/pear/cache
PEAR data directory data_dir /home/kilandor/pear/data
PEAR Installer download download_dir /tmp/pear/cache
directory
[color=#CC0000]PHP CLI/CGI binary php_bin /usr/local/bin/php[/color]
php.ini location php_ini
PEAR Installer temp directory temp_dir /tmp/pear/temp
PEAR test directory test_dir /home/kilandor/pear/tests
Cache TimeToLive cache_ttl 3600
Preferred Package State preferred_state stable
Unix file mask umask 22
Debug Log Level verbose 1
PEAR password (for password
maintainers)
Signature Handling Program sig_bin /usr/bin/gpg
Signature Key Directory sig_keydir /usr/local/etc/pearkeys
Signature Key Id sig_keyid
Package Signature Type sig_type gpg
PEAR username (for username
maintainers)
User Configuration File Filename /home/kilandor/.pearrc
System Configuration File Filename /usr/local/etc/pear.conf

This is config for PECL
pecl config-show
Configuration (channel pecl.php.net):

Auto-discover new Channels auto_discover
Default Channel default_channel pecl.php.net
HTTP Proxy Server Address http_proxy
PEAR server [DEPRECATED] master_server pear.php.net
Default Channel Mirror preferred_mirror pecl.php.net
Remote Configuration File remote_config
PEAR executables directory bin_dir /home/kilandor/pear
PEAR documentation directory doc_dir /home/kilandor/pear/docs
PHP extension directory ext_dir /home/kilandor/pear/ext
PEAR directory php_dir /home/kilandor/pear/php
PEAR Installer cache directory cache_dir /home/kilandor/pear/cache
PEAR data directory data_dir /home/kilandor/pear/data
PEAR Installer download download_dir /tmp/pear/cache
directory
[color=#CC0000]PHP CLI/CGI binary php_bin /usr/local/bin/php[/color]
php.ini location php_ini
PEAR Installer temp directory temp_dir /tmp/pear/temp
PEAR test directory test_dir /home/kilandor/pear/tests
Cache TimeToLive cache_ttl 3600
Preferred Package State preferred_state stable
Unix file mask umask 22
Debug Log Level verbose 1
PEAR password (for password
maintainers)
Signature Handling Program sig_bin /usr/bin/gpg
Signature Key Directory sig_keydir /usr/local/etc/pearkeys
Signature Key Id sig_keyid
Package Signature Type sig_type gpg
PEAR username (for username
maintainers)
User Configuration File Filename /home/kilandor/.pearrc
System Configuration File Filename /usr/local/etc/pear.conf

[quote]I seen in other post long ago about this, about doing the installingphp5, but i’m using PHP5, so I shouldn’t have to install it custom? I should beable to use DH’s PHP5 Somehow but I dunno how.
[/quote]
I don’t think you have to install your own custom PHP5 if you just correct those paths (though I could be wrong about that).

Try this path to the PHP5-CGI executable:

/usr/local/php5/bin/php

–rlparker


#3

Tried that but still no luck. Gives the same error, It can download the package, but it wont’ install it…

Seditio Forge - CMS User ran site
FFXI Mod Communtiy


#4

From the Wiki Article: “It is important that you use export to have the paths stick when using PEAR from the command line.”

Did you do this step? Could failing to do that be what is might be causing the problem ?

–rlparker


#5

I followed these instructions, to set the correct path for php
It is highly suggested that you modify your ~/.bash_profile to ensure that your environment is properly configured to access your local PEAR installation before defaulting to the shared installation. PEAR also tests for the existence of the PHP_PEAR_PHP_BIN environment variable.

If your local installation of PEAR is v1.4.0 or above, you should also update your PATH variable to point to the proper PHP5 location.

Here is an example bash_profile that provides support for PEAR v1.4+ and PHP5 on a shared DreamHost account. It is important that you use export to have the paths stick when using PEAR from the command line.

export PHP_PEAR_PHP_BIN=/usr/local/php5/bin/php
export PATH=/home/username/pear:/usr/local/php5/bin:$PATH

You open .bash_profile, and put those 2 lines in. And then relog your session, for them to take effect and it worked.

But now I have another errror, when tyring to install, with PHP Size

pecl install uploadprogress-beta
downloading uploadprogress-0.3.0.tgz …
Starting to download uploadprogress-0.3.0.tgz (4,677 bytes)
…done: 4,677 bytes
3 source files, building
running: phpize
Configuring for:
PHP Api Version: 20041225
Zend Module Api No: 20060613
Zend Extension Api No: 220060519
/usr/local/php5/bin/phpize: /tmp/pear/cache/uploadprogress-0.3.0/build/shtool: /bin/sh: bad interpreter: Permission denied
Cannot find autoconf. Please check your autoconf installation and the $PHP_AUTOCONF
environment variable is set correctly and then rerun this script.

ERROR: `phpize’ failed

Seditio Forge - CMS User ran site
FFXI Mod Communtiy


#6

As the error suggests - you need to install Autoconf.
Honestly though, I NEVER recommend trying to use the PECL installer on DreamHost. It takes more time to setup/configure than it’s worth. You’d be better off installing a custom copy of PHP5 and then just install each PECL extension afterwards.
We have some PECL install scripts in the DH Wiki that would make for decent examples on how to go about doing so in fact. :slight_smile:


Chips N Cheese - Custom PHP installs and the like!


#7

That really doesn’t help me solve the problem at all…and I see no point in installing a custom php, this will be like the only time I probally ever use it…

Seditio Forge - CMS User ran site
FFXI Mod Communtiy


#8

Well, you’re welcome to continue attempting your PECL installs by installing Autoconf and probably Automake as well into some directory under your user account. Once you’ve done that, you’ll need to modify your .bash_profile to reflect their locations in the “PATH” setting. I believe you need to specify their location in another setting as well, I just can’t recall which one off hand, but you’ll definitely need to indicate which folder each one resides in under the “PATH” setting.

Outside of that - good luck man. I found installing and configuring a custom php to be infinitely easier than playing around with my environment variables in the attempt to get PECL to play nice. Hopefully you have better luck :wink:


Chips N Cheese - Custom PHP installs and the like!